IoT CO2 Temperature Humidity Sensor does not work!

Hi @Anil_Bhaskar and @TravisE_NCD_Technica

We are very sad that we have had too many difficulties with the sensors.

Recently our colleague @adalgiza.rios_gomez ordered 2 more sensors to integrate them to our hydroponic system. Both were working “fine” until we tried to perform a FRC calibration.

Now the sensors don’t seem to turn on, we tried a factory reset (RST + CFG for 20 seconds + 5 seconds + RST) and nothing seems to work.

The SCD30 does not even turn on to confirm that the sensor MCU is working.

The XCTU along with the Zigmo module is able to find the remote module on the PANID 7FFF, but the sensor does not send anything.

The alpha program does not list any of the modules. We don’t know what to do and it is too frustrating to set up a network with such difficult to configure and calibrate sensors.

Please help us, we have only 2 of the 4 sensors working that were supposed to be working weeks ago.

I loaded the Digimesh profile in the Xbee PRO S3B (Sensor_Xbee_EY_EY_ENABLE.xpro & PC_Xbee_EY_EY_ENABLE.xpro) in the sensor and zigmo respectively.

Then, I did a factory reset. The sensor is still not working.

However the XCTU through the Zigmo is able to find and polling the XBee on the sensor. But it does not send any data.

It is just too frustrating. Please help us !

Hi,
just to confirm you mean new sensor are not working but old works or its other way around.

The new ones. We note that these new sensors come with a FW Version 4. The two new ones stopped working.With the old ones (FW Version 2) it does not accept the FRC calibration commands, so they are still working although with wrong CO2 measurements.

I also can’t get the sensors to send data reliably. I’m using an IoT Edge Computer and 2 of these sensors. The data comes in randomly and its very hard to get the sensor to connect to the IoT Edge Computer. Is there a good guide to follow on this topic?

sensor sends data in two cases

  1. when you press reset button
  2. after fixed interval ( its user configurable) default interval is 30 min
    it means it will send data after every 30 min.

every time sensor sends data the status LED will blink once.

node red flows can be found here

1 Like

@Anil_Bhaskar Thank you so much for these, they were very helpful!

Can you please tell me where I can find a guide on how to calibrate these sensors?

Thanks!

i am not sure how it will work with node red.
i will check with our node red developer and see if he can add it for you.

Thank you! The two sensors I purchased are giving very different readings, (10-15% difference) so I have to calibrate them somehow.

@Anil_Bhaskar Will await your response.

the accuracy is around ± 30 ppm/. so if one reads 500 ppm and other one 550ppm you dont have to calibrate

One reads: 84.87 F, 40.13 % Humidity, 575.48 ppm

The other reads: 77 F, 53.11 % Humidity, 655.96 ppm

I think I do need to calibrate :slight_smile:

@Anil_Bhaskar any updates?