I2C Shield for Raspberry Pi with Inward Facing I2C Port - When installing on Pi3, it will not boot

I mistakenly ordered I2C Shield for Raspberry Pi with Inward Facing I2C Port (26 pins) instead or the one with 40 pins for Pi3.
Since the pinout is the same and the shield is “Non invasive”, I installed it on my Pi3. But then, the Pi3 will not boot. It will boot only when I take the shield off.
Am I missing something? Or the 26 pins shield is not compatible with the 40 pins one?

could you post a picture of your setup.

Attached are two photos. It was first with mouse, monitor, etc… So, step by step I took all peripherals off.

Any answer?

This device doen’t work.

did you try it on any other pi ( other then pi 3b+) ?
like one pi 2 or 3 or zero.

I don’t have another pi.

Except for the I2C, is there any special setting needed on the pi?

so looks like there are some changes on the pi3b+ i2c port.
the i2c shield worked on all the pi models except pi3b+.
to make it work i removed the pull up resistor and it started to work ( extremely strange)

the pull up is the 4 network resistor, right above the REV.B text. while removing make sure there is no short/solder bridges on the resistor network pads.

update : it works if i boot up the pi first and then plug the i2c shield.

Resistor removed - still no good.
I also tried this trick. But, I can’t use it this way.
It seems that I will have to order another one (this time the one that is designed for pi3B+ (was it tested?). After making all this way, any discount for the second one?

Pi3B+ boards are in production and will be available in around 3 weeks.


OK. I’ll wait for that. Any discount for the second board :wink: ?

sure, we will apply 8% discount to your order.