Ethernet Modem unable to communicate

Hello, I recently purchased a 2 channel AC current monitor (PR55-4B) and a Wireless Ethernet modem (PR55-17B) to evaluate. I followed the “Getting Started with NCD Enterprise Ethernet IoT Wireless USB Modem” video to setup the modem and I was able to see data from the AC current monitor. The next morning I was working on setting up a Node-Red flow to continue with the evaluation. I had just entered the modem MAC address into the node configuration and went back to the Windows computer with Alpha station to confirm the MAC address of the current monitor when the modem seemed to stop working. I had not deployed the node yet, so pretty sure it had nothing to do with this.

Alpha station could see the modem on my network, but when clicking “Sensor View & Setup” an error, “Unable to Communicate with Modem”, would appear. At that time I was also unable to connect with the modem via browser (ERR_CONNECTION_REFUSED). After a few times of resetting and re-powering the modem I was able to connect via browser, but I was still getting the “Unable to Communicate with Modem” error in Alpha station.

I have read and tried the trouble-shooting steps I could find here in the forum. The last thing I tried was switching to a USB connection and got the same error.

One thing to keep in mind is only one software application can be connected at a time. If you run Alpha Station you must make sure Node-Red is not communicating with the modem.

I read that in the forum and closed down all other possible connections when Alpha station first failed. When I switched the modem from Ethernet to USB that should have eliminated all other possible connections as well.

did you switch the jumpers to USB as well ?
can you share pictures of the modem board

Yes. I switched the jumpers when I attempted to test in USB mode and made sure the baud rates were the same for the computer and the modem.


This picture shows the modem with the jumpers in the Ethernet position.

  1. switch the jumpers to USB
  2. upload radio profile using XCTU
    How To Upload Profile in Digmesh Radio - NCD.io

I attempted to connect to the radio in the modem, but the XTCU software was unable to communicate with it as well. I have opted to send both the modem and current sensor back for evaluation and repair.