Error installing the package

Using windows server 2012 R2 Std
Trying to run:
npm install ncd-red-wireless

and get a lot of error, not sure what did I do wrong?

Try running npm update and then try installing the package. If that does now work let us know what version of node and npm are installed.

Thanks for the reply, issue is related to serial port binding:
npm ERR! code 1
npm ERR! path C:\Users\Administrator.node-red\node_modules\ncd-red-comm\node_modules@serialport\bindings
npm ERR! command failed
npm ERR! command C:\Windows\system32\cmd.exe /d /s /c “prebuild-install --tag-prefix @serialport/bindings@ || node-gyp
ebuild”

Although when I ran serial port install (npm i node-red-node-serialport), it seemed to be installed fine,

These are the versions:

PS C:\Users\Administrator.node-red> npm --version
7.0.3
PS C:\Users\Administrator.node-red> node-red --version
30 Oct 12:53:59 - [info] Node-RED version: v1.2.2
30 Oct 12:53:59 - [info] Node.js version: v15.0.1
30 Oct 12:53:59 - [info] Windows_NT 6.3.9600 x64 LE
30 Oct 12:54:00 - [info] Loading palette nodes
30 Oct 12:54:01 - [info] Dashboard version 2.23.5 started at /ui
30 Oct 12:54:01 - [warn] ------------------------------------------------------
30 Oct 12:54:01 - [warn] [ncd-red-comm/ncd-comm] Error: Could not locate the bindings file. Tried:

I am getting an error during the installation of @serialport/bindings@2.0.8 as well. I am using node 14.15.4.

If anyone else hits this problem, I was able to solve it by removing node v14 and installing a previous version on the v12 line. At the time of writing, v12.20.1 was the latest on that line.

@duelingcats can you elaborate more on how you removed the version and how to install v12, I am facing the same issue.

Thanks in advance