Endnode no more recognized by usb wireless router

Is it possible to hard reset an endnode module to its factory settings with some kind of internal button? For some reason, our endnode is no longer recognized by our usb wireless modems. We have made the following checks: PANID is 7FFF, there is no Device ID conflict, we haven’t changed the encryption password. We have tried the soft reset of the endnode, it’s hard reset and its factory reset using Alpha Station. Nothing works, the endnode is still not recognized by the usb wireless modems. Thank you for your help.

Please let me know more about the device that was changed (2.4GHz, 868MHz, 900MHz), also, please let me know the process you used for changing these settings (Did you use Alpha Station to make these changes?). I can look into this further for you. Also, please let me know the ASM part number printed on the cover so I know exactly which firmware you are running.
Thanks,
Ryan

Hello, Ryan,

It is an ASM1-6 900 MHz (0-10V Analog to Digital converter). I work with the latest version of Alpha Station.

My project is:

  • I need to access industrial wireless sensors and an Endnode from the same computer…
  • As the computer must be able to receive data from industrial wireless sensors and at the same time send queries to the Endnode, I use two USB wireless routers.

At the beginning of the project, I thought that both routers need to be on different PANIDs. While researching your site, I later learned that two Endnodes can have the same PANID.

So, at the beginning of the project, I changed the PANID of one of the two routers to 7FFE.

Then I connected the Endnode to the computer with the USB cable and tried to change the PANID of the Endnode to 7FFE with Alpha Station. I had access to the Endnode configuration window but most of the changes I made were not saved. So it was impossible to save the new PANID in the Endnode. Note that the routers were disconnected during this operation to prevent the Endnode from trying to connect to AlphaStation using wireless…

Seeing this, I then tried to connect to the Endnode from the router using the 7FFF PANID since the Endnode PANID remained 7FFF but this was impossible. It is now impossible to connect to the Endnode wirelessly in both data read and configuration mode. However, it is still possible to connect to the Endnode with the USB cable.

I then tried to reset the XBee module using pin 5. I also tried to reset the Endnode with the little pushbutton inside the box. I even tried to use a spare XBee Digimesh module that we have at the workshop. Nothing works. It’s still impossible to connect to the Endnode.

By the way, and this is very curious, although it was impossible to save a new PANID in the Endnode, I did succeed in saving secondary settings such as country and Device ID. All other settings remained unchanged.

Thank you for your help.

I will check this when I return to the office. Last time I tested it, the Pan ID was able to be changed without problems, along with the other settings. The software should display changes, but again, I will double check this. Normally, these settings only need to be changed if you are working on a big install and you need to put these devices into different wireless groups, otherwise the default settings can be used for most applications. Also, the Wireless Encryption key is a write only field, it cannot be read and always appears blank. If you changed the encryption key from the default, you will need to change the Modem encryption key as well to match it. Typically you do not want to remove the module and attempt any other form of recovery other than the software we have provided, if you set the module to it’s default settings, endNode firmware will not be able to communicate to the wireless module and a return would be the easiest way to recover the module profile. This will definitely cause our software to not correctly display or change settings.

If you want to attempt to change settings of the Wireless module yourself and dig a little deeper, you can use X-CTU software (free from Digi) and tear apart your modem to make sure both wireless modules have the correct profile, but we do not support this as the process is far too lengthy and time consuming for us to support. If you are daring, we can send you the endNode profile to upload into the wireless module if you want to try this. Otherwise, please plan a return, we will be happy to recover it for you.

Hello, Ryan,

Well…

  • The encryption key hasn’t been changed ;
  • The original Digi module has been put back in place and it doesn’t work either.

You know, I have already delayed the installation at our client’s place because of this problem. So it would be great if we could fix the problem together without me having to send the module back to you, which would cause additional delays. My client is getting impatient…

So…

  • I would appreciate it if you would send me the default profile. This one is to be installed with XCTU I presume.
  • If your tests put you on a track, I would appreciate it if you let me know as soon as possible.

Thanks for your support

Hi Bert,
All end node and modem use same xbee profile and it can be found here

PC_Xbee_EY_ENABLE.xpro

Good morning,

I ran some new tests this morning.

1- I tried to use XCTU to reset the ASM1-6 (0-10V Analog to Digital converter) XBee module using the files mentioned by Bhaskar. Unfortunately, the scan of the network of the wireless modem couldn’t find the ASM1-6. I also tried to access the ASM1-6 using the USB cable. Again, XCTU couldn’t find it.


2- I then asked myself the following question: could it be the XBee module of the wireless modem that is the problem? So I tried to use XCTU to reset the XBee module of the wireless modem with the files: PC_Xbee_EY_ENABLE.xml and PC_Xbee_EY_ENABLE.xpro. I got the following error messages.


I’ve been testing for almost 2 days now to fix the problem. I must admit that I’m starting to run out of ideas. In addition, my customer is unsatisfied that I had to delay the delivery of his system.

Therefore, I would appreciate any help you can give me.

Thanks

Hi Bert,
are you trying to upload profile to a remote xbee over wireless ?

I will recommend following

  1. take a module out of the ASM and plug into a USB modem and upload the profile in the module
  2. upload same profile in the USB modem wireless module which you are planning to use to talk to ASM module.

Hi Bhaskar,

I tried both ways: wireless and with the USB cable of the ASM. I’ll try what you suggest. I’ll get back to you very quickly with the result.

Thank you

Hi Bhaskar,

You are saying to upload the same profile in the ASM AND the router. The Sensor_Xbee_EY_ENABLE.xpro profile in both?

Not the sensor the PC profile
PC_Xbee_EY_ENABLE.xpro

Sensor profile is only for devices which are powered by battery

Ok. Just to be sure :wink:

I’m trying it right now !

Hi Bhaskar,

This is what I get when I try to upload the Sensor_Xbee_EY_ENABLE.xpro profile into the ASM?

error

Here is a screenshot of the xml file

The .xpro file gives the same message as before

I never seen this kind of error in past.

are you following these steps ?

Alpha Station software was updated to properly display the Network ID settings, they were being stored, they were not displaying in the software correctly. A default button was also added, you will need to click Store button at the bottom of the configuration page to apply the default settings to the controller.
Alpha Station may be downloaded from this link, be SURE to uninstall the old version.

Hi Bhaskar,

These are the steps I took.

I went over it again, just to make sure. The datarate, the password, and the panid are the same for the sensor and the router.

Okay, it’s working now!

Here’s what I did:

  1. I followed the information given by Bhaskar to the letter in order to set the PANID, datarate and password of both modules using XCTU.

  2. I’ve updated Alpha Station as proposed by Ryan.

  3. As this was not working yet, I connected the ASM to the PC with a USB cable and did a soft reset in the Alpha Station configuration interface.

  4. In the Alpha Station connection screen, I clicked on the Default Address Settings button in the Endmode setting zone which reset the address to the default value. Then I entered the actual MAC address of the Endnode again and it started working again.

Here’s what I think:

  1. The password and PANID have always remained the same for both modules.
  2. Maybe the datarate was different between the two XBee modules

In anyway, I carefully keep the procedure provided by Bhaskar in case it happens again!

However, there is still one remaining question: why have I never been able to reset the XBee profile using XCTU? Why did I get these strange error messages?

Thank you very much gentlemen for your help! I know a client of mine who is going to be very happy that it works and it’s to your help that I owe it :slight_smile:

Have a good day !

Hi Bert, Glad to know you have it working. I never seen that XCTU error so not sure what might be causing that.

I will recommend not changing default setting in future just to be safe.

Thanks

1 Like