Could not connect with Xbee sensor using Base Station


I have installed NCD Base station and tried to configure and read data from 2-Channel AC Current monitoring sensor. I followed the instructions given in the document ZigBee_Mesh_Quick_Start_Guide for Base Station set up.

I followed step by step instructions in chapter 3 - setup. Till 4th step it is working fine. I can see “Your device is ready to use” dialog box. Then if I select the appropriate Com Port, Baud Rate and click OK, It shows “The controller did not respond to the baud rate you selected” and starts searching other baud rates, finally exits.

Intention is to read from the sensor using Xbee in both ports (I2C is a different discussion). It may be helpful even if I need to do it via XCTU if not in Base Station. (All XBee modules were in 115200. Then tried with 57600 and 9600 as well).

I tried the same with NCD Environmental sensor and got the same results. Tried with Xbee module alone without any sensors and got the same.

Xbee module details:
IC: 1846A-XB900HP
Model: XBee PROS3B
(I believe Base Station supports XB900 S3B)

Thanks in advance.

here are few thigns i will check

  1. Make sure the xbee module installed in the current sensor has correct config. if you are not sure you can upload PC xbee profile in the modem as well as in the xbee plugged into the current sensor
    The settings i will recommend checking is baudrate, pan id and ENY settings and Key
  2. wireless sensor does not work with base station.


Thank you @Bhaskar

I updated the profile in both sensor and receiver. Viewed the receiver side data in XCTU. No signs of sensor sending any data. Am I missing something? And I see that in sensor profile Baud rate is 9600 and in PC side it is 115200. Is that intentional?

wireless battery powered sensor baudrate – 9600
wireless current sensor ( external powered) – 115200

HI Bhaskar,

I’m having a similar issue with our new 2 Channel 4-20mA (PR55-47_2CR). Using Alpha Station…Com3 115200. I can see the sensor report in the Address, Description and Signal Strength - but the Sensor Readings field reports “Unknown Data Source”. I can also update the configuration. But no data is being reported…Not supported with Alpha View?

Hi Mark,
Unknown means its not supported.

@ryan1 can you add this sensor when you get a chance.


Yes, I will add to Alpha Station early next week. Please prepare a sample for testing and leave it on my desk.

new alpha station online