Control ProXR through protocol translator

Hello, we are using a software called axia pathfinder. This has a built in protocol translator that should be able to send basic commands.

The setup works as follows: ProXR connected to a Blackbox ethernet serial server via serial cable.

Control works from BASE station software via IP connection to the blackbox.

However pugging the commands into the pathfinder software does not work. The RX LED lights up on the ProXR so I know comms are working just not getting the right commands.

I have tried decimal and hex formats as well as something like this: \xAA\x03\xFE\x6C\x01\x18 Which was found in another thread.

Also tried with carriage returns and line feeds but not sure what the proXR is actually expecting.

Any help would be greatly appreciated!

So is the connection on your ProXR controller Serial? If so ensure that the baud rate of the Black Box Ethernet to Serial converter is set to a baud rate of 115200.

Yes it is serial out of the blackbox to the ProXR.

It was set to 9600. I have now tried 115200 but still not working properly.

The software manual has this:

Protocol Translator Command
This Action will send a textual message out a
Protocol Translator port. Select the Translator
and enter the command to send.
Escape characters can be used to look for nontypable
characters as follows.
" \\ = \ "
\cr = Carriage Return
\lf = Line Feed
\t = Tab
%xx where xx is a hexadecimal number
represents an Ascii character of the number
represented by xx

But I’m still not sure how to format the command properly.

It looks like the format for Hexadecimal commands is:
%FE%6C%01
That command should turn on relay 1.

I swear I had tried that with no success but now after trying again it is working,

Thanks for the help!

No problem. Please let us know if we can help with anything else.