Configure Wireless IoT ORP pH and Temp sensor with Microsoft Azure Gateway

So I recently purchased the Wireless IoT ORP, pH, and Temperature Sensor and the Micro Gateway for Microsoft Azure. I was able to setup an IoT hub and a create a new device successfully with the modem but I am unsure of how to setup the ph/ORP sensors to send data at certain intervals to Azure. I downloaded Alpha Station and put in the correct IP address and endNode but my modem doesn’t show up.

My ultimate goal is to have a live stream of this data sent to Power BI. Can anyone help? I have already read the product manual but the manual describes hot to set up the sensors with a USB modem, not a wireless modem.

Hi,

Alpha Station is not compatible with the Micro Gateways. It is only compatible with Modems.

The first thing to check is to make sure your sensor is powered on. We ship the sensors with the power off so they do not drain battery during shipping. Open the lid and either flip the switch towards the closest wall of the enclosure or move the jumper to the pins closest to the enclosure wall.

On power up the sensor will send a transmission which the modem will receive and forward to Azure. You should see the sensor data appear in the Device Twin on Azure inside the nodes object.

By default the sensor will report every 10 minutes I believe(@Bhaskar can confirm this). If you want to alter the report interval of the sensor you can do that by following the information in this guide:

Also if you do not have it already here is the guide for the Azure Gateway:

If you have any other questions please let us know.

Thank you,
Travis Elliott

Thank you for the feedback. The sensor was turned on, I already removed the top cover and switched the device on. After reading a little more, I found out that the sensor sends readings every 10 mins by default. I need to figure out how to calibrate the pH and ORP probes now. And be able to get the streaming data out of Azure and into Power BI.

Hi Austin,
The probes are calibrated.

if you still wish to calibrate you can do it. the calibration process can be found in the product manual.

The default data transmission interval is 10min. its a user configurable parameter and can be changed by going into sensor configure mode.

Thanks

I have followed the instructions for trying to change the parameter in configuration mode but the sensor doesn’t show up on the devices tab. I tried pressing and releasing the reset button on the sensor to force a transmission but it still doesn’t show up.

Hi Austin,

Can you open the sensor and the gateway. Then pull the wireless XBee module out of them and send a photo of the bottom of the modules? This will allow us to see if the correct modules were installed.

Be sure to not get them swapped around though. Make sure you install the same module back in the gateway and the same module back in the sensor. They are different.

I think the correct modules were installed because the sensor was working with the default 10 min interval. I changed the parameter to 1 min so I wouldn’t have to wait so long while testing this in our lab, but the data won’t show up on the device twin in Azure. The gateway updates but the sensor does not send anything to the gateway. The metadata and nodes “last updated” tags are different. The only one that updates is the metadata. And it only seems to update when i force a transmission through during configuration mode.

Also, the timestamps on the data are not correct. How do I change that?

Hi Austin,

We have no control of the timestamps. That is 100% managed by Azure. Azure posts the timestamp when the reading comes in. If it looks incorrect it is probably because it is referencing a different timezone than yours.

If you scroll up in the Device Twin you should see the actual data objects above the Meta Data.

It is our job to get sensor telemetry data to Microsoft Azure. Once the Data is on Azure it is between yourself and Azure as to how you want to handle it. Azure can provide support for handling the data. There is just too much information for a small company such as ourselves to support when it comes to AWS IoT, Microsoft Azure, etc.

Ok good to know. I was looking at getting assistance from Azure anyways.

Thanks!

I read the manual, I dont have the usb modem so if I want to send calibration commands via the gateway, do I just send the command as a message under the ‘message to device’ tab in Azure?

@TravisE_NCD_Technica can comment on Azure gateway.

the other way to do it is
upload the mega modem firmware in Azure gateway and use it as a USB modem to calibrate the sensor. After calibration update the firmware back to Azure.
https://ncd.io/how-to-ncd-grepy/

Hi @austin_paradigm,

Currently there is no way to do that with the Azure Gateway. It is possible to alter some basic settings like the report interval through the Gateway’s web UI but it is not possible to do any calibration of the sensor through the Gateway. For that you will need a Modem as Bhaskar suggested.

Great… These probes are being deployed to an industrial setting with slightly alkaline and acidic environments, and from what I’ve gathered from the product bulletin is that I may have to calibrate them as much as once a month. These sensors are kickass but now I have to purchase an additional modem to perform routine service.

My suggestion: There should be an advisement or notification when purchasing the pH/ORP sensor stating that you can only calibrate them with the USB modem. I have no problem purchasing the modem but this requirement sets me back a week.

Hi @austin_paradigm,

We apologize for that. This is a brand new product. It is not common for our sensor devices to require regular calibration so it is something that has not been integrated into the gateway devices yet. I will more than likely add handling for this in the future.

Good to know. Which modem configuration do I need to order for this sensor? There are two options:

1.) Standard Compatible with NCD Industrial Devices
2.) API compatible with IoT Long Range Wireless

I’m assuming the second option but I wanted to confirm.

You will want the API Compatible with IoT Long Range Wireless version.