Configuration web page on NCD Ethernet to I2C converter is blank

I am using Firefox browser to setup an NCD Ethernet to I2C converter via its configuration page. The issue is that there are no factory defaults shown on the page. On a previous device, it came up with default settings and I just modified the IP address and left everything else the same. I have tried resetting to factory defaults and also clicked on the button for reset device. I have tried setting all of the fields (guessing at some values) but the values do not seem to stick after a power cycle. How can I get the configuration page to show some values?
Note we don’t have DHCP on this network and are currently using the static IP jumper for the initial access.
Attached is a screenshot of the device summary page. Note that not even the MAC address has a value:


Can you let me know what firmware version your device has?

You should be able to find it through the NCD Config Tool:

Run it and expand the MAC Address on the left.

Additionally you can set your settings through the config tool while we look into the web page.

The firmware version is whatever was shipped on devices from NCD just a few weeks ago. It is a new device. We currently don’t have a Windows machine on this network to run the ConfigTool executable, nor is Wine installed due to the current security profile. It is currently on a network with Linux machines. It would be great to have a ConfigTool port to linux!?

I scanned thru some old screenshots of settings from a previous board where we saw this issue as well. The firmware on it was reported to be version 2.1, but note that this is not the current board as this previous board was destroyed when we shipped the prototype from one site to another. As noted in the previous reply we currently don’t have a good way of running a ConfigTool compiled for a Windows machine. Note that every once in a while, the configuration page does get populated with values (not blank), but it is not often and has not happened recently, otherwise we might have already gotten this board configured correctly.

I would love to get the web configuration page running on this device, but am open to configuring this device via other TCP commands. Apparently there is some sort of API for the ConfigTool to use. I wouldn’t mind writing my own config tool for our linux environment, but I would need info on the API.

Firmware version is 2.3


As strange as it seems it looks like there’s an issue loading the existing settings from browsers not running on windows.

We are looking into resolutions for this, but in the mean time the only solution we have is to configure the settings from a windows PC.

Ok thanks, we have been able to configure this board by moving it to a Windows computer for configuration with the ConfigTool. Hopefully, you all can figure out the web page configuration on non-Windows based systems before we have to configure many more of these boards.