Communicating with Relay Controllers

We have purchased several Industrial High-Power Relay Controller(s) 2-Channel + UXP Expansion Port(s) with the SKU of ZUXPR220PROXR. For communications we are using the Ethernet to Serial Communications Module - New Gen 3 that has an SKU of NCD5500.

At this point we have successfully communicated with the NCD5500 using the configuration software, and when we access the relay controller using the Alpha Station software, on the Select Communication page, the device is discovered and displayed just fine. However, once the OK button is selected, a new window is displayed showing sections for Identifiers, Utilities and Control Panels. Only the Control Panels section contains any values which are Sensor View and Setup and Communications Recovery which is basically of little use for controlling relays. The documentation that I’ve been able to look at, go on to discuss sensor control and monitoring with little or no information on accessing and controlling relays.

I believe that between the NCD Base Station software and Quick Start Guide, Alpha Station software, ProXR Standard software, ProXR Enhanced software, NCD5500 Ethernet Module Web Interface User Guide, NCD Gen3 Ethernet Module User Guide and the NCD5500 Config Tool Software, I have become a bit confused as to which set of information I should pay attention to.

I would think there would be a way that is a bit more straightforward to access these two relays. Does anyone have a valid suggestion that may help with communicating with this controller board?

You will need to use Base Station as Alpha Station is for Enterprise class controllers only.

1 Like

Fantastic! I’ll give it a try, thank you very much!

No problem, let me know if you have more questions.

So, when running the Base Station software v4.0.8 a window pops up that has among other things, a display section and 2 buttons off to the side labeled Device Identification and COMM Operator. In the display section is a message stating that Device Identification Failed.

Then the COMM Operator button is selected and the COMM Operator software starts. Based on the tutorial Using Comm Operator to Control Ethernet Relays, an attempt is made to determine the IP address from a UDP broadcast. Since the static IP jumper is installed on the two pins directly to the left of the Ethernet Jack, the documentation states that the IP address should be So, the UDP broadcast is being used just to obtain the port number. Unfortunately, even though a message is displayed on the very bottom of the window frame indicating Connected |Link1|UDP with the expected IP address. No information is displayed in the Log Data section.

Since the IP address is known, an attempt was made to use the TCP client tab to attempt to open a connection to the device using the known IP address and port 2102 which the tutorial indicates is the usual value. After doing this, a message is displayed in the same place as when attempting to receive a UDP broadcast at the very bottom of the window frame stating Connecting|Link1|TCP Client with the expected IP address. That message appears to display indefinitely.

Therefore, I’m kind of at loss as to how to proceed. Any suggestions would be appreciated.

Ryan T

I’ve done a bit more digging and I think I’ve found the problem. On the specifications page for the Pro XR controller, there is a specification that states that the Pro XR provides 3,3v and a maximum of 100ma. The specifications for the Gen 3 Ethernet Module states that 3.3v and 300ma are required. It goes on to say that an upgrade for the power supply to the communications module may be required and is available.

I would like someone from NCD to provide the SKU, part number, and/or anything else that we might need
to obtain the required items to operate the Pro XR relay controller as advertised. If we need to purchase new controller boards or communications modules that is fine, just so long as I can get this order as soon as possible.

If you can send your controller to us, we will be more than happy to upgrade the hardware to the updated power supply at no charge. This upgrade is included with new purchases. We are also upgrading the design of the boards to include this, but this particular controller has not yet been upgraded.

That sounds good, but for right now, and for the sake of expediency, we would like to go ahead and order several Pro XR controllers and Gen 3 Ethernet Modules, preferably to be sent using a rush delivery option. Is the fastest method to order through your web site, or is there possibly a quicker way?

The fastest way is to order from our web site, the order is directly processed by our manufacturing division, so they start to work on it once the order is received. Please let me know if you have more questions.

That’s great. However when I look at the Industrial High-Power Relay Controller 2-Channel + 8-Channel ADC at the specifications still state that the Ethernet Communications Module Power Consumption maximum is 100mA. How can I be sure that the boards I order will have the upgrade to accommodate the 300mA power requirement for the Ethernet to Serial Communications Module - New Gen 3

That’s correct, when they are ordered together, our production department includes the upgraded power module. This is required or they will not pass testing. You could also include this in the notes for special instructions, but it should be caught during manufacturing. The upgraded power supply is capable of 300mA easily.

Okay, received the new Industrial High-Power Relay Controller 2-Channel with UXP Expansion Port boards with the Gen3 Ethernet communication ports already attached. It definitely looks as if it has a higher amperage power supply for the communication module.

Unfortunately, I still am unable to communicate with the controller. I have a jumper installed to force the static IP address of and I’m running an Ethernet cable directly from my laptop to the Gen3. I have swapped out all cables and boards in the event one of them may have been faulty. I have even disabled the wireless adapter on the laptop to insure there is no crossover from one network to the other.

When I run the NCD ConfigTool I get the following…

Which appears to only aid in configuring the controller.

If I run the NCD Base software, a Select Connection window is displayed from within I select the Network option and input the static IP address using port 2101. When I select OK the expected control window is then displayed, but in the Command Sets panel section of the window there is only the single statement Device Identification Failed. No further steps appear to be available

I feel at this point I have hit a brick wall. I have no idea what I could be doing wrong. Is there any chance I could get a very specific set of instructions that match the exact controller I’m attempting to communicate with?

I will recommend checking out this post

I will tag @TravisE_NCD_Technica on this one for review as well.

Hi @davidcornelius Try using Comm Operator inside Base Station to establish a TCP client socket connection to the board’s IP address over port 2101. Comm Operator will tell you whether or not it was successful in establishing the TCP socket connection to the module. This will help determine if there is a connection issue with the Ethernet module or an issue with the relay controller.

Thank you,

I’m sorry, I thought I had mentioned that I had attempted to use Comm Operator. In any event, I just tried it again.

Just to make sure I’m getting this right, from the 1st window that opens for Base Station, I select the Network radio button and leave the High speed network profile for ethernet module check box selected. I set the IP address to and the Listen Port to 2101 and then select OK.

The next window states that the Device Identification Failed so I elect to start the Comm Operator software. Once the Comm Operator is up and running, I select Open Connection from the File drop-down menu and the Open Connection window is displayed. According to the document titled Using Comm Operator to Control Ethernet Relays I then select the TCP Client tab at the top of the Open Connection window. From the TCP Client tab, I again set the IP address to and ensure that the Connection Port is set to 2101. I then select the Open button.

All that I get is a message at the bottom of the Comm Operator window indefinitely stating that it is Connecting [Link 1] [TCP Client] | 2100 | Recvd: 0/0 | Send: 0/0.

That is about all I get. There doesn’t appear to be any indication at all of whether Comm Operator succeeded in establishing a TCP socket connection or not.

So, am I doing the right thing in the right place?

does the TCP/IP LED comes on the ethernet module ?

If i were you first i will test the unit through a router and make sure everything works.

Having a hard time determining which of the two LEDs is the TCP/IP LED, but they both come on intermittently.

As for testing communications through a router, I have attempted to use an unmanaged switch (which is what will be used in the final product) without establishing any communications at all.

I will attempt to find a router


in a prior message, you referenced a post concerning the inability to connect via a static IP in which you stated

Were you ever able to resolve the issue or obtain additional information on the subject?

user was able to get it working and posted the solution over there
TCP/IP led is on Ethernet module.

@TravisE_NCD_Technica is giving it a go as well