Alpha Station does work with I2C Master Hardware


I have a I2C Converter with Dual Serial to 8-Port Hardware I2C - Master Device connected with USB to my laptop. However, when I connect my device and try to run alpha station, I face a problem I am not able to solve.

Alpha station finds the device on the COM-port, so I can choose COMport 5 and then click on okey. But afterwards I see this window and nothing happens anymore :

When I click on Sensor View and Setup I get an error and when I click on Communications Recovery, I see also an error.

Some additional comments :

  • Alpha station works without problem when I run it together with a Megamodem and environmental sensor.
  • The light of the USB adapter is always flashing red
  • It is not the baud rate because I changed the baud rate several times to 9600 and back to 115200.
  • I tried it also on another laptop and I had the same problem which reduces the probability of firewall issues.
  • I use Alpha station
  • I have a Hall effect sensor I want to use with the MasterDevice

Thank you for your help


You want the AnyI2C software, not alpha station. AnyI2C can be found here:

Alpha Station is for our Enterprise line of wireless sensors.

Thank you,
Travis Elliott