Alpha station and I2C 16port HUB configuration problem

Dear All,

I have troubles in getting my I2C relay banks connected / configured to the 16 port I2C hub.
Connections are USB and Ethernet. Alpha Station: 1.0.2.14

In Alpha Station is use the: “I2C Bus Scanner and ProXR linker”
I press “scan I2C ports”

And yes: The connected MCP230xx boards are detected. (Stated as: ‘MCP230xx -Driver Undefined’)
Then i “Edit” the drivers to the correct MCP boards.
Then i change “Run mode” to “Configuration mode”
I press “Write New Driver Map”. → i see storing counting up…

When then opening the ProXR Enterprise, i cannot control any relay…
I scan my I2C ports again, and still the same result as initially: 'MCP230xx -Driver Undefined"
So my changes are not stored.

What am i doing wrong?

Thank you.

@ryan1 can you look into this.

Today i tested it with a single 8 port hub and that one worked immediately…

So what the problem is with the 16 port, i don’t know.

The only thing I can think of is keep the Program/Run jumper in the “Run” position at all times unless the software prompts you to change this jumper. Also, be sure to power up the controller with the jumper in the “Run” position. There are lockouts in place that prevent some functions from operating while in configuration mode. If the controller thinks you are in configuration mode, it will likely lockout relay control functions. Please let me know if this helps. Thanks, Ryan

Unfortunatly this not works. I did exact the same thing with the 8 port hub, and that worked right away.
Then again did exactly the same thing at the 16 port: no storage of the devices.

Can i send this unit back in for checkup?

Absolutely, but if you can, I would like to take a look at the memory chip on the board. Would it be possible to take a photo of the board with all communications modules removed? The memory chip responsible for storage is a small black 8-pin chip.

Dear All,

Thank you very much for this excellent service! I have received the new base boards Friday.
I have removed the old TOP board and placed it on one of the 2 delivered base boards.

I use alpha station 1.02.14 and at Hardware i only see PR54-11 8 channel multiplexer, not the extension board.
With I2C bus scanner is can see all connected devices from port 1 - 8, but not from 9 - 16. I assume i have not checked some kind of checkbox to read extension port?
The bus scanner now also writes the correct values and so i can control my boards.

Attached are some printscreens. I also see one port? My hub is connected with a ethernet interface on port 1, and a usb interface on port 2. I don’t know, but should i see 2 port’s?

Thank you.



I am checking into this to see if it can be changed remotely, but I am thinking this is a firmware change…I will get back to you on this.