4-20ma Wireless Transmitters

I have 7 4-20ma Wireless Transmitters. When I first started to set them up I think I followed a bad set of instructions and have been attempting just to get connected to them and see them talking to each ever since. I fear that I have made so many changes and tried so many different things, who knows how badly I have messed them up. Is there a default configuration that I can load onto them to start all over? I have had the most success connecting to the radios through XCTU, but now I understand maybe is more preferable to use Alpha Station (which it seems like I could connect to it in the beginning, but not for a while now). I also have a USB wireless gateway and an ethernet wireless gateway I am trying to set up. So a total of nine devices.

Thank you.

Hi Kyle,
I will recommend running factory reset setting.
this is how it can be done

  1. Press release reset
  2. Hold cfg for 20 seconds
  3. release cfg button
  4. wait for 5-6 seconds
  5. hit reset
    This will bring back all the settings to factory default.
    Make sure your modem PAN ID is set to 0x7FFF.

Let me know if you run into any issues.


What about the USB Gateway and Ethernet Gateway? They don’t have a reset button and I’ve played with the settings on those as well.

I suppose I should also ask if it is okay to use the USB Gateway as the device that I connect to the other sensors with? Or do I need a different device to connect and configure the sensors?


After doing the factory reset, Alpha Station says that it cannot communicate with modem, and base station says that the baud rate is wrong (115200 is set for the port and the modem) and it tries to negotiate a new baud rate, unsuccessfully. Now that I have reset XTCU will not recognize the device either. This is all connected to the USB gateway which I reset by taking it out of the USB gateway box and putting it in one of the sensor boxes and following the reset instructions.

I tried going to Base Station and selecting “More” and then ZigBee set up, but it cannot find the modem there either.

base station wont work with these sensors.
Lets use Labview UI to configure and test.

You can use the USB modem to read the sensor and same modem can be used to configure the sensors.

I will recommend doing this

  1. download and install the labview ui
  2. open the ui
  3. select correct port and 115200 as your baudrate
  4. sensor on router configure
  5. read PAN id and make sure its 0x7FFF
  6. if its not set it to 0X7FFF
  7. now go back to main UI window and click run mode
  8. hit reset on one of the sensor and you will data coming on the UI

Okay, this worked and I was able to connect to one of my sensors. How can I change the settings on the sensor node as to how often it reports and things like that?

you can the sleep duration and node id by going into config mode
here is a video which shows how to conf ncd.io wireless sensor

I only have two nodes that will talk to each other. I guess the one I connected to was one of the nodes I have never reset. I am unable to reset any of the other nodes using the method listed, the configuration stays the same. I hit the reset button, and then I hold the config button for twenty seconds. Is there any way I can copy the configuration of the node that is working to copy it to the others?

So actually to describe it a little better, Node A I can connect to in Labview and it is working perfectly. Node B I can only connect to in XTCU. I cannot see Node A in XTCU, and I cannot see Node B in Labview. Using the same modem.

I’ve been loading the recovery profile onto some of the modules using XTCU. I’m noticing that none of the modules that I loaded that profile onto will connect in Labview, and they will not reset to the factory configuration.

I was mistaken about it being fixed. For some reason I had only one of the seven sensors would connect through Labview. I have tried resetting the sensors to factory default, but it appears to have no affect on the sensors. I can get two sensors to see each other in XTCU by plugging the Zigbee module into the USB Gateway and putting the recovery configuration on them. But there is no connectivity in Labview or anywhere else. The one sensor that I can see in Labview, I cannot connect to in XTCU to see the configuration.

the sensor wont show in xctu because Modem S3B PAN id might be different than 0x7FFF.
lets do this

  1. factory reset all sensors
  2. upload recovery pc profile in the usb modem
    we will move to the next step. We will use Labview to view the data and change sensor settings.

its not recommended to unplug the xbee module and uploading the recovery files in the sensor modules.

Is there anything I could have done that would not allow me to factory reset the sensors? I have tried the steps 10 or 20 times on each sensor and it will not reset the module. Unfortunately I have already uploaded recovery files to the sensors by plugging them into the gateway because I am extremely crunched for time to find a solution. Again factory resetting the sensors doesn’t appear to have any affect. I tested this by changing the PAN ID on one of the sensors and then trying to factory reset, but the PAN ID doesn’t change. So I am unsuccessful with step 1. All the PAN IDs are correct, I have verified them in XTCU. I am now sending data to the gateway from the sensors by setting the analog pins to ADC and setting the delay time between transmits. Unfortunately right now, the raw data is always showing 1023 for all four analog pins. Sorry to make it difficult, but I appreciate your help.

no worries i will give you a call in few minutes and will walk you through the recovery process.


Thank you again for your help this morning, you definitely saved the day.

For anyone who might come across this, I had foolishly reloaded all of my XBee Pro S3B modules with the recovery profile because I thought that I could not connect to any of my sensors. However, the reason I could not connect to any of my sensors was because I changed the baud rate from 9600 to 15200 to match my USB Gateway so I could connect through XTCU. Although that did get me connected through XTCU, it killed my connections through LabView and Alpha Station. What I didn’t realize was it is correct for the baud rate to be 15200 on the USB Gateway (and probably any other gateway for that matter) and 9600 on the sensor nodes. As long as you can connect through LabView you will be good to go everywhere else, including Node-Red. So I wouldn’t recommend XTCU for anything but recovery.

Hopefully nothing in there is inaccurate or misleading, but I though it might be helpful since I sifted through a ton of documentation on and off of NCD.io and never found that information.

All of that sounds accurate except for a typo: baud rates referenced as 15200 are actually 115200 or 115.2k baud for the gateways/modems. For anyone referencing this later.