4-20mA receiver not transmitting to usb hub

I had previously connected a 2-channel 4-20mA receiver to a usb gateway the other day and it worked well. I shutdown my computer and now it doesn’t seem like it’s connecting to the gateway anymore. I did update the data update frequency to 10 seconds and it looks like batteries still have power.

It doesn’t look like there are any indicator leds in the housing.

I’m using a Windows PC.

What software were you using to monitor data from the USB modem? Node-Red, Alpha Station, etc?

When the USB modem is connected to the computer do you see it appear as a device under COM/LPT ports in the device manager?

Thank you,


I’m currently using Alpha station on Windows. The modem shows up with IP address, listen port 2101

Hi, I replaced all of the batteries and now it works. I checked the voltage of each of the batteries provided and 2 of them were dead.

are you powering any sensor using the on board power supply ?
if yes how frequently are you transmitting the data ?

I am using the board power supply at 15s intervals for quick verification that it works. However I am having trouble getting a signal using the , but trying to configure to use powered transmitter.

4 of the 6 batteries have good voltage, but 2 are completely dead.

I have a 4-20mA driver I am using to debug that has a 24V PS.