XBEE WiFi Compatibility

Hello all,

I have been working with the Fusion 2-Channel Controller Lately along with the XBee 900MHz Pro S3B, and XBee WiFi (sold on Digi). I have the XBee 900 MHZ working properly thanks to a wonderful post I found on this forum.

I currently have the XBee Wifi creating an ad-hoc style network which I connect my phone to and use a TCP/UDP terminal, from which I can send Hex or Ascii text. The fusion board seems to be OK which taking data from the XBee Wifi module (Busy light flashes on when Hex Commands are sent). I however have not been able to figure out what commands I need to send to turn on and off Relay 1. The Xbee 900Mhz command I used doesn’t work (I believe its due to the Wrappers those commands need). I have tried commands from here:

Which were very helpful for the XBee 900 Mhz along with the NCD api-calculator.


  1. Is Xbee WiFi compatible with NCD Relays? (If they are not this is all I need to know. I have one of your wifi modules on order but dont have enough time for for when it gets here to work on it.)
  2. I have noticed jumper pins labeled “Ad-hoc” would those have anything to do with the wireless network?
  3. Any guidance on using the XBee Wifi along with your relays?

Any help is appreciated, hope everyone has a wonderful day.


Those commands are specifically for ProXR, but I believe those particular commands are shared between these two series.

Is this XBee WiFi shipped and sold by us? If not you’ll probably need to edit it’s settings to talk to the board. Specifically the serial port coming out of it needs to pin match (probably does being an XBee footprint) and needs to have the baud rate 115200.

The same commands should work over WiFi and DigiMesh (900MHz). If the busy/ready lights are blinking then the board is getting data it just isn’t understanding it for some reason. An incorrect baud rate would do this.

I bought the Xbee through Digi. The Baud rate is set to 115200
I have the “Serial interfacing” section of the XBee WiFi as close as i can get it only difference is on the API option
on XBee Wifi its : XBee API Rx indicator - 0x90
on 900 Mhz its : API Rx indicator - 0x90

We don’t support the XBee WiFi module, but it should still work.

The WiFi module that we carry is more designed to be on a network and accessible over TCP/IP.

Do you have an XBee to USB adapter that you can use to read exactly what is coming out of the XBee WiFi module when you send it a command?

So I figured it out. It was an addressing issues I believe. With the 900 MHZ mesh you need to state which node you are sending a command to. In my situation with a singular node on Wifi I was simply able to send a command to all endNodes (the only 1). Using the commands from the spread sheet it worked flawlessly.
Thank you for your help.