Wireless USB modem can't find analog voltage sensors

I have a wireless USB modem PR55-17A It’s got the settings from the attached file. PC_Xbee_EY_ENABLE.xpro (66.0 KB) which as I understand it should be the default, plug and play settings.

I’m able to communicate with the modem over USB and read its PAN ID as 7FFF. However, I can’t get the modem and software to recognize any packets from my new analog voltage sensor PR52-10. I’ve tried waiting 15 minutes and I’ve tried hitting the reset button while scanning with the mode. Either approach should result in data being sent, but I’ve had no success.

I have moved the power jumper from its factory position so that the XBee is powered, with 3.3V from pin 1 to pin 10. I’ve done some poking around with my oscilloscope and it looks like DIN and DOUT are active when I press the reset button. I tried looking at the signal on the antenna’s leads, but if there is one, I didn’t see it.

Does anyone have any other suggestions?

what is the distance between 0-10V and modem ?

does both of these have antenna connected ?

did it ever communicate with the modem ?


They’re about six inches away from each other. Both have their antennae connected, and I’ve never been able to get them to communicate.

the minimum distance has to 3-5 fee.


Ok, I put them 6 feet away from each other and still have the same issue.

I will recommend following

  1. factory reset the sensor
  2. open the USB modem in xctu
  3. open serial port
  4. hit reset and see if you get a “RUN” msg in serial terminal


I was able to get packets in the serial terminal following your advice. I then opened Alpha Station and was able to see the devices and configure them as needed. Everything is now working as expected. Thanks!