Unable to receive sensor data from edge computer in node red

Hello everyone,

I am currently trying to receive data from 2 sensors. The sensors I am working are a vibration outdoor sensor and a vibration indoor sensor. I also have in my disposal the IoT edge computer.

The problem is that I am unable to receive any data

I have tried the following:

  • Connect my computer with the edge computer, disable the aws flow and created a flow with just the gateway and one of the sensors both connected to a debug node, the gateway node is connected and ready. On the sensor node at the serial device field I have selected the /dev/ttyS1, I have filled the Mac address, selected Vibration on the sensor type and ticked Auto config. I have experimented with multiple node-red configurations but still I cannot get any data on the debug window even when I press reset on the sensors.
  • Make sure that the sensor’s switches are on and have battery
  • Put the sensors in configuration mode
  • Restart the sensors
  • Restart the geteway
  • Factory reset the sensors
  • Factory reset the geteway

I also have a second edge computer, and I have tried the above with that device to no avail.

I don’t know if I am missing something but I had connected some other sensors in the past with an edge device and as far as I remember it should be a straight forward process and the gateway should detect the sensors with no extra configuration.

Any help will be appreciated
Thanks in advance



A few things that cause a problem like this:

  • Can you check that the wireless modules in the gateway and in the sensors are the same frequency? If you’re unsure you can attach photos of the sensors and gateway and I’ll take a look.
  • Can you check your configuration nodes for duplicate ncd-gateway-configs that reference the same serial port. You can access these from the menu in the top right > configuration nodes.
  • When the gateway is in configuration mode do you get any messages from the sensor when they go into configuration mode?
  • When the configuration button on the sensor is pressed, does an LED come on? If not can you try the same with the power switch in the other position to check for an LED?

Also this getting started video may be useful:

I second Jacob’s recommendation to check module frequency. Please provide top down photos of the IoT Edge Computer and the Sensors with the lids removed.

Thank you for your replies,

  • I am attaching the requested photos bellow.

  • How do I change the frequency of the gateway?

  • No I did not get any messeges when the gateway is in configuration mode.

  • Yes the LEDs are turning on when the configuration button is pressed.

(I know that the switch is in the off position in this photo)

whats your online order number ?

Hello, my online order number is #511592

There was no gateway purchased with this order ID.
Do you have any other order ID.

Sorry for the confusion,

these are all the order ids:

All your past units were purchased with 868mhz radio modules but this last order ( 511592) was purchased with 2.4ghz.
I recommend returning the 2.4ghz module, and we will send you 868mhz radio module.