Type 80 DeadBand OTF Configurable?

Is the Deadband value for the Single Channel Vibration Sensor able to be configured via the OTF Configuration?

And setting Deadband to 0 would disable it right?
(Disable as in, we want the sensor to pickup all vibration, even very minimal amounts).


yes, it can be set via OTA.
yup 0 means its disabled


This a very interesting feature!
Where can I find the in’s and out’s of doing this?


Two Channel Vibration V3 node and LTE gateway.

Setting Deadband zero will introduce some noise when the machine is off. It will pick the vibration from the surrounding area.
There is no disadvantage to setting it to zero.

@leenve the general way to do this is to use the ncd-red-wireless-2 Node-Red library.

That Node-Red library gives you two objects, a ‘Wireless Gateway’ and a ‘Wireless Device’ node.

The Wireless Device node is the one you want for this.

Configure the Wireless Device Node with the Modem (Serial, Serial Device for Config) and then choose the sensor type.

If you only want to config a specific device in this manner, choose its mac address (if it has transmitted and been heard) or type it in. I think lowercase is necessary with colons.

Check the box for Auto Config, and OTF Config. The OTF Config is the key to doing what you want here.

Then scroll down and check the Set Dead Band

The sensors check for config on about the 4th minute of every hour if their Real Time Clock (RTC) is enabled. They then talk to the gateway, and get the new setting applied.

In my experience this works pretty will but I tell people it will take a few hours to get applied, and also depending on how many sensors, and what their Node_Ids are.

The Node_Ids are enough to fill a separate post, but are important not to have too much nodeId overlap because the timing of that OTF Config is 4th minute of hour + (nodeID * 5sec)
If you have too many sensors all on the same nodeID they might all respond/talk at the sametime and overwhelm your RF.


In my Node-red device settings-tab I do not have the option “OTF”, see attachment.

Do I have not the latest Node-red environment on my Linux Gateway perhaps?


You may not have ncd-red-wireless-2 or you may not be running the newest version of ncd-red-wireless-2.

On linux, using a terminal, try the following.

Stop node-red
Command: node-red-stop

Change directory to the node-red directory
Command: cd ./node-red

Uninstall ncd-red-wireless and uninstall ncd-red-wireless-2
Command: npm uninstall ncd-red-wireless-2
Command: npm uninstall ncd-red-wireless

Install ncd-red-wireless-2
Command: npm install ncd-red-wireless-2

Start Node-Red
Command: node-red-restart

Hi kstokes,

Unfortunately I can’t get these commands working in my Terminal, see screenshot below:

Also the npm commands do not work.

Any suggestions?

Many thanks.