Temp / Humidity Sensor Data = 0

I just setup a Temp/Humidity long range enterprise sensor, routed it though an Azure Gateway, got it streaming to an IoT Hub. I can see the device telemetry coming in at regular intervals but the the sensor data for both the Temp and Humidity is 0. Do I need to do something to initializing this or is it defective?

yes it looks like sensor element is bad.
can you check and see if there is any physical damage

Looks mint in the box to me. Just got it in the mail yesterday. T/H board looks good. Solder points all look good.

Tried a reset. No effect
Tried power off / on. No effect
Is there anything I should try in config mode?

@TravisE_NCD_Technica is there a way to display firmware version of the sensor

I just updated the Azure firmware to include the sensor firmware version in the telemetry. Your Azure Gateway can be updated using these instructions:

1 Like

Well that is awesome. I’ll get to work on that.

BTW I work for Microsoft and am trying to put together a demo of industrial IoT on my own. I was hoping that your gateway would interface with Azure IoT central which is a super slick way to get data published. Unfortunately this requires some work on your part at the firmware level to update to our Device Provisioning Service model. If you can get that working, I think I could sell a bunch of NCD devices to researchers and facilities operators looking for IoT to be easier.

Azure IoT Central documentation | Microsoft Docs

1 Like

Issue: I dont have a modem. I am just using the web interface.

Can you send me one that works?

you can update the gateway firmware using the link @TravisE_NCD_Technica shared.
in order to connect the gateway to the computer you will have to take the board out of the enclosure.

I want to see what’s the firmware version of sensor.

@clay.hagler we actually worked with another team from Microsoft and they got everything working for their project using our Azure Gateway and wireless sensors.

Going through the Device Provisioning Service however was not possible. They were still able to get data in dtdl format for their use case however without changes to the Azure Gateway firmware.

1 Like

I don’t see any instructions on how to physically interface with the board.

Open the Azure gateway box, pull the circuit board out, you will find a USB connection on it.

1 Like

Found one on the board with the Expressif chipset. I assume this handles all your comms.


1 Like

Found your handywork: Firmware version is 10

1 Like

I cannot get the replacement sensor you sent me to show up on the gateway!. I have turned it of/on, checked the battery alignment, hit reset, reset+config(8sec), reset+config(30sec). Nothing seems to make it appear in the devices menu and I don’t see any node data in my messages on Azure.

Another oddity that may (or not) be related. The gateway will not stay in config mode. When I connect to it with chrome and select the device menu, I get about 30 sec and then it reverts back to run mode an recconects to Azure.

Please help, this is attempt #2 to test NCD for my irrigation district project and I am losing faith.

Hi Clay,

As for the Gateway not staying in Config mode. Make sure you are not powering it over the USB connection, you must connect a 12VDC power supply to the Gateway in order to keep it powered up.

Who did you work with in getting a replacement sensor? If it’s just a normal Temperature/Humidity Sensor then there should be support for it in the Azure firmware. @Anil_Bhaskar can you please confirm there have been no major changes to the Temperature/Humidity(Sensor Type 1) sensor packet byte structure?

@clay.hagler can you please post a top down photo of the Azure Gateway and the wireless sensor in question both with their top lids removed?

@TravisE_NCD_Technica sensor type 1 packet structure has never been changed.