SSL connection Wi-Fi Micro Gateway for MQTT

Hi there,

I am facing problems when trying to connect to ssl://domain
a) it does not allow me to use ssl://
b) when i use without - and trying to use with Use Secure Connection: On - still not working.

Could you help / advise how to enable ssl:// domain connection ?

Got no problems when connecting from local computer via Python client :

import certifi
import paho.mqtt.client as mqtt1

client1 = mqtt1.Client(“P1”) #create new instance

Also - could you share some documentation on how to access debug logs ?
When Controller arrived - had big problem on setting it up and it is impossible to see whether it is problem with WiFi setup or problem witth MQTT server settings.

Hi there,
Anyone could suggest something - this is purely lack of technical documentation.

The MQTT Gateway is a very simple device. It does not have built in logging.

Can you provide screen shots of the settings you are entering into the Gateway?

We have never had a user attempt to use a Host URL for an MQTT Broker which begins with ssl://. It may be necessary to transition to the IoT Edge Computer instead of the MQTT Gateway as it is a more robust/capable device for “non standard” use cases such as this.

Hi There,

Gateway does not allow me to put Domain with ssl://
So the only option i had was to use Domain without ssl:// and tick box for Secure connection.
Problem i see is i am not sure if this gateway is failing on MQTT connection or WiFi.
Due to the lack of documentation ( can anyone help me to identify colors and what those indicates please ? (since also no access to logs)