PR55-3 Thermocouple to PR55-17b Modem problems

I am trying to work with a single channel Thermocouple PR55-3 connected to Ethernet Modem PR55-17b. I can connect to the modem both in Comm Operator and Alpha, but the thermocouple seems to be sending bad data… Under Comm Operator, it shows a power-up frame but then doesn’t receive the interval readings. When running Alpha under vs2017 debug I see “ERROR HEADER REJECTION:-1” at intervals in the debug output. I can get an accurate reading from the thermocouple if I hit the reset button inside of the housing but it does not give subsequent readings until hitting the reset again. I have been through much of the documentation but I can not seem to nail down the issue. Here is a paste of more debug output from vs2017:

READ IDENTITY
Reading EEPROM:
254
50
3
64
31
End Reading EEPROM
Exception thrown: 'System.Exception' in NCDEnterprise.dll
Exception thrown: 'System.Exception' in NCDEnterprise.dll
Exception thrown: 'System.NullReferenceException' in Alpha Station.exe
READ IDENTITY FINISHED
EXIT READ SETTINGS
Read Activation...........................................................................
Device Activated Function Call
Reading EEPROM:
254
52
30
48
16
End Reading EEPROM
Exception thrown: 'System.Exception' in NCDEnterprise.dll
Exception thrown: 'System.Exception' in NCDEnterprise.dll
The thread 0x4dbc has exited with code 0 (0x0).
STALL: 1
.................................GET DESTINATION HIGH FINISHED
Timer Start ------------ 
Exception thrown: 'System.Exception' in NCDEnterprise.dll
Exception thrown: 'System.Exception' in NCDEnterprise.dll
---------------------ERROR HEADER REJECTION:-1
 ------------ Timer Stop
Timer Start ------------ 
Exception thrown: 'System.Exception' in NCDEnterprise.dll
Exception thrown: 'System.Exception' in NCDEnterprise.dll
---------------------ERROR HEADER REJECTION:-1

Hi,
the sensor sends data after a fix interval. by default this interval is set to 10 min.

You can change this interval by going into configure mode. for configuration i will recommend Labview utility which can be found on product page under resources section.

Thanks

I can’t figure out how to get labview to work with the Ethernet modem, only has options for connecting on COM1 port. Also, alpha station hangs in configuration mode… Is there a hex string I can send over Comm Operator to set the interval?

just updated the labview utility . you can it with ethernet now.


You cna find the configuration commands over here

Thanks

Which runtime does this use? I installed the 64bit runtime for the serial labview tool and the one you’re sending me tells me i don’t have correct runtime.

did you install this one
http://www.ni.com/download/labview-run-time-engine-2017/6822/en/

Nevermind I figured it out, it needed the bottom-most link, the 32-bit sp1 version from here http://www.ni.com/download/labview-run-time-engine-2017-sp1/7191/en/. I was able to update the interval! Thank you for the help.