PR52-33N filtering and data rate

#1

Hello,

I’m trying to set the filtering and data rate for PR52-33N sensor so I modified your node-red library, adding a few functions for setting time series flag, filtering and data rate.
First off, can you please confirm these functionalities are supported for my sensor type?

After i do the sensor configuration, the USB modem outputs this JSON:

{“topic”:“Config Results”,“payload”:{“destination”:true,“id_and_delay”:true,“power”:true,“retries”:true,“network_id”:true,“time_series”:true,“filtering”:true,“data_rate”:true},"_msgid":“1f9865bc.7b660a”}

Secondly, can I assume the configuration is correct since Config Results show no error?

After configuration the sensor stops sending anything except for this JSON:

{"topic":"sensor_mode","payload":{"mac":"00:13:a2:00:41:8b:c0:a5","type":40,"nodeId":0,"mode":"RUN"},"_msgid":"55c4058a.fc94dc"}

Thirdly, these are the functions I’m using, am i correct to assume all these flags have 1-byte length?
// SET TIME SERIES: 0xF4 / 0x08 / TS
config_set_time_series(sensor_mac, bool) {
var packet = [244, 8, 0, 0, 0, bool];
return this.config_send(sensor_mac, packet);
}
// SET FILTERING: 0xF4 / 0x02 / F
config_set_filtering(sensor_mac, bool) {
var packet = [244, 2, 0, 0, 0, bool];
return this.config_send(sensor_mac, packet);
}
// SET DATA RATE: 0xF4 / 0x03 / ODR
config_set_data_rate(sensor_mac, rate) {
var packet = [244, 3, 0, 0, 0, rate];
return this.config_send(sensor_mac, packet);
}

Thanks
Horia

#2

Hi Horia,

  1. yes, the sensor type 40 supports time domain analysis.

  2. did you enable time series using Labview utility ?

  3. @Trey do we support type 40 in node red?

#3

did you enable time series using Labview utility ?

No, I enabled it via node-red - via the function i added (config_set_time_series).
The sequence that works:

  1. In the sensor configuration, set the time series flag (config_set_time_series)
  2. Wait for sensor’s first transmission, then immediately
  3. Write the Time domain data transmission command to the modem
  4. I start receiving the 12 packets which i recompose and this way i get my time series data

However, the default data rate is 25600 Hz (ODR value = 15).
I want to change that to a lower bandwidth let’s say filtering enabled and ODR value = 5, which will give me according to the documentation 58 Hz bandwidth.

The sequence I’m trying to do that in is:

  1. In the sensor configuration, set the time series flag, set filtering and set data rate (config_set_time_series(1), config_set_filtering(1), config_set_data_rate(5))
  2. Wait for sensor’s first transmission - but this is where it blocks and sensor isn’t sending anything anymore

Can you give me some hints on how i could debug this issue?
Is it possible to get some support from your engineers?

Regards,
Horia

#4

I believe the sensor is in config mode while you are change the datarate.

  1. can you share the complete command which is going from node red to the sensor?
  2. After sending the command do you get a confirmation from the sensor that the data rate command was a success.
  3. after configuring the sensor did you change the modem pan id back to 0x7FFF?
#5
  1. 7E00 1410 0D00 13A2 0041 8BC0 A5FF FE00 40F4 0300 0000 07C1
  2. Yes, the object i receive in node-red after sending the commands is

{“topic”:“Config Results”,“payload”:{“destination”:{“err”:“No config err or ack, timeout”,“sent”:[[0,19,162,0,65,139,192,165],[247,3,0,0,0,0,0,255,255],null]},“id_and_delay”:{“err”:“No config err or ack, timeout”,“sent”:[[0,19,162,0,65,139,192,165],[247,2,0,0,0,0,0,0,10],null]},“power”:{“err”:“No config err or ack, timeout”,“sent”:[[0,19,162,0,65,139,192,165],[247,4,0,0,0,4],null]},“retries”:true,“network_id”:true,“time_series”:true,“data_rate”:true},"_msgid":“5fbfe28.5246a1c”}

  1. Yes, I suppose that is done when i press the config button in node-red to indicate “modem in running mode”
#6

use this command to change the BW
7E 00 14 10 00 00 13 A2 00 41 8B C0 A5 FF FE 00 00 F4 03 00 00 28 05 E8

and this one to enable filtering
7E 00 14 10 00 00 13 A2 00 41 8B C0 A5 FF FE 00 00 F4 02 00 00 28 01 ED

Thanks

#7

That worked, thanks

Horia