PR33-16 Is not detected by Raspberry Pi

I’m trying to use a PR33-16 with my raspberry pi but unfortunately it cant detect it.

Connections are as follows: PR33-16 – PR2-1 – MCC 134 Temp module – Raspberry pi

I try to run: “sudo i2cdetect -y 1” But it only shows me empty grids and not the I2C device address which I’ve set to 68 and 69 on the two channels. I am also using the 4.7k pull up on the PR33-16.

I have the i2c-tools and python-smbus libraries installed, I2C enables in the rpi configurations. And I believe I have the right cables connected but still cant detect the device.

It has the power light on but nothing else.

Any help would be appreciated!

By default I2C is not enabled on the Pi. You will need to enable it. There are guides online that cover that.

I had already enabled I2C, and checked it again now, still no luck.

I’m not sure what other troubleshooting steps to try. You might try removing the shield below the I2C shield to see if that makes any difference.

Tried that too, any way I could check the status of the module other than the power LED light?
I checked with a multimeter and the I2C ports are getting power, anything else I could check to troubleshoot?

The only other thing I can think of is if there are any scripts running on the Pi that are consuming the SDA and SCL lines that might cause conflict.

Remove the Pull Ups you have them installed wrong.

Tried it again without the pullups, still not showing anything. Might have to check the SDA, SCL line overlap.

your old jumper settings were shorting SCL SDA lines.

Do you think that damaged the pi or the any of the other components? Also isn’t it supposed to be across the terminals to use the 4.7K on board the PR33-16 as stated on its resources page?

I was checking to see if the 4.7K on the pi is not working maybe.

installing pull up like this wont damage the board.

Check the pull up installation direction again. It should be installed horizontality not vertical.