Old board vs new swapping USB and LAN interfaces

I have a testing board from 2014 (R8xPL rev A) and a board received yesterday (ZADR81DPDTProXR). When I swap the LAN interface on the old board for the new USB interface, the old board does not communicate. When I swap the new board’s USB interface with the old LAN interface from the old board, the new board does not communicate. When I use the old board with the old LAN and new board with the new USB they work flawlessly.

Am I missing something?

Thank you, Ed


The older Ethernet module won’t work on the newer board as the older Ethernet module is most likely of the type that uses a third row power pin (check the pins on the underside of the ethernet module). The new Ethernet modules do not have this pin and the row was removed from newer boards.

The USB module should work for both old and new boards. Is your computer able to detect the serial port when the USB Module is installed on the older board? Is Base Station (Start - ncd.io) able to detect the Serial port and communicate with the controller? If so you might check the Device Configuration in Base Station for Both the Baud Rate and UART Technology as outlined in the section Titled “Device Configuration” of the Base Station quick start guide: https://ncd.io/base-station-quick-start-guide/

Hello Jacob:

Thank you for your reply.

You are right that the Ethernet interface we have has a single pin in a third row. That solved that.

As to the USB, I just tried the old board with new USB interface using our control software. It came up and works flawlessly despite my unplugging the USB cable, dropping our software, etc. I think we might need to make our control software’s Port ID a bit more robust. At least that is what I will suggest to our IT guy along with using Base Station as testing software…forgot about that.

Many thanks for your time.