Not receiving data via modem from light sensor

#1

We have just bought a [industrial-iot-wireless-ethernet-modem/] and a light sensor. I have connected the modem to the internet but the sensor is not transmitting data. Or I am not receiving it. How do I set it up? The modem is on a closed network.

0 Likes

#2

Hi,

Can you tell me a bit about your network? Are you running this wireless to ethernet modem off of a headless switch?

Where are you trying to send the data?

0 Likes

#3

No we are running the modem off a meraki router. So basically we plugged in the modem and downloaded com operator and ncd base. Followed the directions for both but we are not seeing any data come back through.

0 Likes

#4

Eventually we will be wanting to send the data to an application that we are going to write in c#.

0 Likes

#5

Well, by default the ethernet modules require a DHCP enabled router. You can configure a static IP address into them to work on non-DHCP enabled routers, but it must be configured first.

Is the ethernet device showing up on the router?

Can you check the jumpers on the sensor to make sure that they’re in the battery power position as outlined on this diagram:

0 Likes

#6

Awesome that did the trick. Now is there a way for me to check what the sensor is seeing at any given time. If not, can I change the default 10 minute reporting time to 15 seconds. And how do i know what the data is saying all im seeing is this.

0 Likes

#7

here is a visual studio software which can be used to view the data and config the sensor

0 Likes

#8

Im getting the following errors when trying to run the project. Any thoughts?

0 Likes

#9

I’m not an expert on VS, but it appears to be that your windows machine doesn’t want to run it because it has “the mark of the web”. Its a cool sounding phrase, but I’m pretty sure it just means that you need to manually approve running it. This page has a bit of info on it: https://docs.microsoft.com/en-us/visualstudio/ide/reference/trust-settings?view=vs-2017

0 Likes

#10

So i tried to change the delay to 30 seconds and now the sensor doesn’t respond any more. Did I do something wrong? Is that delay to short?

0 Likes

#11

after setting the delay you will need to hit reset.

0 Likes

#12

I hit reset and no data is being transmitted.

0 Likes

#13

check the modem PAN id. is it 0x7FFF?
could you screenshot of the ui?

0 Likes

#14

The panid of the sensor was something else but now it wont even show up

0 Likes

#15

it wont show up the if sensor pan id is different. you can perform a factory reset( hold reset and cfg button, release the reset button while keep holding the cfg button for 15-20sec. release cfg button and after 5-6 seconds hit reset).

0 Likes

#16

So if I change the delay to 30 seconds then I will also need to change the panid to 7FFF ?

0 Likes

#17

first lets read the sensor config by clicking “Read Sensor Configuration”

0 Likes

#18

That is what is displayed when I click “Read Sensor Configuration”

0 Likes

#19

If I use the forced option then this is what comes up

0 Likes

#20

this doesn’t look correct. i will run some test cases over here and will get back to you.

Thanks

0 Likes