New Taralist controller with LANx not Cooperating


I purchased 2 new Taralist controllers with LANx modules a few years back and never got around to using them until now. They are fresh out of the package and when trying to set them up via DHCP the port LEDS on the LANx keep blinking off then back on. – Im not sure why its doing this as I cant find any reference to this symptom in the LANx Setup Guide PDF. for a moment the DHCP server sees the device and assigns an IP, but the LANx just keeps going off and on and as a result, I cant bring up the web GUI and configure properly. I have tried resetting and clearing the device to no avail.

Any ideas would be greatly appreciated.

Ok so here is an update~ I took one of the taralist relay controller home to try and It connected up to my network just fine. So my my issue above is related to the network at work. However, I cannot get BaseStation to communicate with any controller. I have two taralist controllers in working environments right now and they work just fine, but I cant get base station to connect to any of them to make configuration changes. I have tried several computers each with a different os version. Windows 10, Windows 11 and windows server 2019. Im really at a loss with base station.
Attached is a screenshot of a message i get sometimes trying to start Base station. This has appeared on both windows 10 latest build and windows 11. Not sure what it is telling me…


I’m not a Windows expert, but it sounds like your user doesn’t have permissions to open a UDP listener or there is some permissions restriction between your PC and the network.

You might still be able to open a socket to communicate if you select Network and enter in the IP address and port manually.

Other than that you can try and run Base Station as admin to see if it’s a user permission issue.

Thanks for your reply Jacob -

As soon as I start Base Station, that popup happens. When I click OK, Base Station terminates. I dont even have a chance to select Network and try a direct IP.

That being the case you’d have to try running as admin.

Additionally it could be an issue between your PC and your network. If you have a VPN running you may need to disable it temporarily. A firewall could also block this.