NCD5500 Webhook Activation

I’m using a NCD5500 module on a PROXR Lite board to control a relay. I’m trying to send commands via webhook to turn relays on and off. I can get the relays to successfully turn on and off using command sets and POSTS in POSTMAN, but it only works if I am logged in to the NCD5500 Web-i. If I am not logged in, I get a Timeout response and the relay doesn’t respond.

Here’s my curl statement:
curl --location --request POST ‘IP ADDRESS/webi_control.cgi’ \

–header ‘ISAJAX: yes’ \

–header ‘Accept-Encoding: gzip, deflate’ \

–header ‘Accept-Language: en-US, en;q=0.9’ \

–header ‘Content-Length: 20’ \

–header ‘Origin: http://IP ADDRESS’ \

–header ‘Referer: http://IP ADDRESS/’ \

–header ‘Content-Type: text/plain’ \

–data-raw ‘170,4,254,48,0,0,220:’

Do I need to authenticate in some way?

You may need to disable the password requirement in the module. You can do that through the configuration software. Let me know if that does it or not.

Hey Travis,

Is that through the NCD5500 Config Tool?

Hi Travis,

I don’t see a way to disable the password requirement; just to change the password. I am in the NCD ConfigTool, but there’s no setting to enable/disable authentication requirements. Am I looking in the wrong place?

I haven’t been able to find where to disable the password requirement. Is that in the web interface? Or the NCD Config Tool? I’ve looked at both and am not seeing a password option (other than to change the password)