NCD Library not loading

I’m trying to load the NCD library in Node-red. After running this command “npm i ncd-red-wireless node-red-dashboard" in windows CMD. and i get this as the results. ( the site say to disregard the errors ) After running it i checked my Node-Red buy i do not see the NCD library added. What am i doing wrong?

@jacob can you take a look into this when you get a chance

I havent used node red much but i managed to install on my machine in few minutes
here is what i did

  1. install node red
  2. go to node red folder
    cd ~/.node-red/
  3. sudo npm i ncd-red-wireless node-red-dashboard
  4. start node red “node-red”
  5. go to your dashboard port. for me it was

You will see something like this

All set.

Windows handles the install a bit strangely. Installing nodejs globally puts it in the program files directory and requires admin access. These errors indicate it is attempting to install the library into your program files folder and doesn’t have permissions.

Try and run this command from ~/.node-red folder. Or try and install it using the palette manager built into Node-Red’s front end.


Yep I did try to run that command from the node-red folder on the C drive. and it still doesn’t show in the dashboard.
So i tried to install the “ncd-red-wireless” palette from the palette manager and i got the following error.

ncd-red-wireless error.txt (35.4 KB)

i tried installing on pc using

    Using cmd: node --version && npm --version
    npm install -g --unsafe-perm node-red
    run node red ==== node-red
  4. open node red
  5. go to manage palette
  6. install ncd-red-wireless
  7. install node-red-dashboard