NCD IOT Edge Computer firmware Reset


I have got a NCD iot Edge computer with me and I have done a firmware reset on the device. But after the reset all the files were erased and I have the onion omega os with no functionality in it. There are no directories and files in it. I can only access the terminal.

I tried the steps for firmware reset but the omega OS couldn’t detect the USB drive and also /mnt/sda1/ is not found on the os.

Any help is really appreciated

do this

cd /mnt/sda1



Thanks for the quick reply. But the error is sda1 doesn’t exist.

remove the usb stick and connect again.
sometime you might have to use a different USB stick.

Thank you so much. But I tried with two USB sticks but it failed. I am having two sub folders in mnt but when i plugin the usb i am not getting the additional folder to mount on. Do i have to preconfigure anything before i plug in. Could you let me know if there is a GUI for reading the USB device.

Thanks once again for the help

I will recommend formatting the USB driving and copy all the firmware files in it and give it another go.

do you get any sub mount message when you insert the usb stick.

I have tried formatting the USB and also tried with a new USB but it was of no use. I am not getting any submount messages when i mount and unmount the device. The linux console is also not working well and is crashing several times.

Is there any possible way that i could schedule a call with the technical team and get it resolved. I thing there is some problem with the firmware .

if the USB doesn’t mount not sure we can do much over call. the best option will be sending it back for a replacement.

what kind of power supply are you using.

if you dont mind sharing what prompted the factory reset operation?