Multiple wireless-ethernet modems

Hi all,

I currently have about 25 temp./humid. sensors connected to a single wireless-ethernet modem.

As I am making my way through the facility with additional temp./humid. sensors I have gone out of range of the wireless-ethernet modem.

I have additional wireless-ethernet modems that I can setup for these additional temp/humid sensors. Is there anything specific I need to be aware of for this to work? this would be an additional ncd-gateway-config node, correct? Do I need to change the Network ID from the default of 7FFF on the modem and on the nodes connecting to it?

Running node-red on ubuntu.

Is there anything specific I need to be aware of for this to work?
Not really, the wireless modules can make their own networks and have their own encryption keys. Additionally You can just plug in the modem and not connect it to the network and it’s wireless module can act as a repeater to get the data to the original Ethernet Wireless Modem.

this would be an additional ncd-gateway-config node, correct?
Yes, it will have its own config with its own TCP connection.

Do I need to change the Network ID from the default of 7FFF on the modem and on the nodes connecting to it?
Need to? No. Personally I would change the Network ID and have them act as two independent wireless networks if you wanted both Ethernet Modems to act as modems. It keeps things in seperate boxes which is nice for defining scope (also easier to explain to people who didn’t set it up and aren’t familiar with the wireless technology). If you don’t change the network ID you’ll get messages from the sensors on the original 900MHz network as you’ll actually be on the original 900MHz network.

@Pitmaster, if you just need to extend the footprint of your Network, you can do so with a temperature humidity sensor.

Use an AC/DC adapter and the dc plug instead of the batteries. You will need to swap the power jumper, and change the XBee Radio configuration (XCTU) to not sleep. That sensor node will then build a Mesh Network with your Gateway, while it still reports the temp/humidity readings at it’s normal schedule.

1 Like


Where do I jumper for dc power? I do not see any locations to jumper it.

The engineers have been migrating the jumpers into a switch, but this diagram outlines the correct position in the red “Important” box in the bottom right:

Makes sense and it worked. Do I use XTCU to turn sleep mode of or will changing the delay to 0 seconds using Alpha Station do the same thing?

you will need to use xctu for disabling sleep mode.

by changing delay the sensor will start sending data non stop.

Brain fart. Thanks.

I have the devices all going to a wireless to ethernet ncd modem. Is it possible to connect to each device using XTCU through the modem or will I need this:

Yes, you will need one of these.
XCTU does not support ethernet .


You could also try a virtual serial port setup, but I haven’t personally tested it.

I’m not familiar with them so I can’t recommend one in particular

So I now have this.

After starting up XTCU I can find this connected to my computer and have added it to my radio modules list (baud rate of 9600). I then plugged the sensor (see below) into a power adapter (I confirmed the sensor is getting 3.3v using XTCU).

When I go to Networking mode in XTCU the only other device that shows up besides the one connected to my computer is the ethernet to wifi modem. No other end nodes are found (including the device above).


Also - I have the power jumpered and delay set to 1s on the LR temp/humid sensor. Using AlphaStation I have verified it is being seen by both the ethernet-wifi modem and the usb modem connected to my computer.

correct the others wont show up.
Try this
put sensor in cfg mode and see if it shows up.

else will need to take log route

  1. open the small USB modem
  2. take the xbee module out
  3. open the sensor box
  4. take the xbee out and put this xbee in USB modem
  5. open xctu and go to sleep setting and change it to normal
  6. put this module back into sensor and you are good to go.


1 Like

The long method worked great! Thanks.

1 Like