MQTT gateway red status light

MQTT gateway connected fine a few days ago, but when firing it up today the esp status light goes to a solid red after a while.

in addition, it also showed a very dimmed blue/red light, but then back to solid red.


That indicates the Gateway is not able to connect to the MQTT broker. I would ensure that the connection information you entered is still valid. You can use a software client on your computer like MQTT.fx to validate the connection info you have entered in the gateway.

Yes, for some reason it had losts its configuration.
It can connect now.

But now I have a different issue with the message format.
I’m using it to publish to the losant platform and I get the messages but it’s telling me " * Payload must be an object in JSON format."
My setting "Sensor Message Format: " is currently “{::Sensor_Data::}”.
Is that what’s wrong you think?

Change it from {::Sensor_Data::} to ::Sensor_Data::

I did that, and now I get " * The data property must be an object."

Ok. Try {data:::Sensor_Data::}

It’s been a while since I worked with Losant but that sounds right that it requires an object keyed data. You can look more at their docs here:

almost. It had to be {“data”:::Sensor_Data::}
It works now

Awesome! Let us know if you need anything else.

For future reference we actually have a Losant Gateway that takes care of pretty much everything for you if you go with Losant as your cloud provider.