MQTT Gateway on Corporate Network


I have a gateway that has worked fine connecting to simple networks and mobile hotspots.
However I have been trying to get it to connect to our corporate network (which uses a controller based wifi system) and running into issues.
On any other network I get a solid green light and packets to my broker.
On the corporate network I just get a white blinking light indefinitely.

I have been working through it with our IT and the main roadblock we are coming into so far is that we are not able to verify the mac address of the device or see any unknown mac addresses trying to connect to these WAPs.
I connected just the gateway and my laptop to a hotspot and ran ARP to find devices and think I have the mac address but we have no logs of the address hitting the network.

Is there a definitive way to determine the mac address or any other steps we should be taking to get the device on the network?


Hi Marc,
Is there any special characters in the password ?

@travis1 do you have any idea.



No special characters, just letters and numbers


Are you using in DHCP mode or static IP mode. If they office network does not support DHCP that might cause the issue.

@travis1 is the lead gateway developer and he will more insight.


Hi Mark,

As @Bhaskar mentioned I would ensure that the network you are connecting the gateway to supports DHCP, if it does not then you will need to enter static IP information on the Advanced tab in the Gateway configuration interface.

Also ensure that the WiFi Access points support 2.4ghz. These gateways do not work with 5ghz networks. Does the WiFi AP show up in the network selection drop down menu in the Gateway’s configuration interface?

I had never actually noticed up to this point that the Gateway’s MAC address is not visible in any way. I will be sure to updated that on future firmware updates. Could you connect it to another network which it worked with and get the MAC address from that network router? That is the simplest way I can think of to retrieve it.


The network supports DHCP and 2.4ghz.
The network is showing up in the dropdown.

In my initial troubleshooting I did exactly that in connecting to another network.
I have what I think is my MAC but not seeing that show up at all on the corporate network.

Any other ideas?


Hi Mark,

No, honestly that one has me stumped. If it shows up in the network drop down then it should be able to connect(WiFi frequency is good, implemented security is compatible, and the AP is within wireless range). Are you sure there isn’t something else preventing the device’s connection to the network? Some large corporate networks only allow connections to authorized devices(AP has a list of approved Mac addresses). Is there a network administrator you could consult with?


Sadly our network administrator is the person from IT I was working with that I mentioned in the first post.
When I did the test of connecting the device to a hotspot to see a small subset of Mac addresses to figure out the device’s Mac address, we added every Mac address we found to the APs.
What the administrator is saying is weird is he can see all Mac addresses that try to access the network, whether they have been added or not and when I select the network in the GUI and reset the gateway he does not see any new Mac addresses attempting to connect to the network.

Its almost as if even though I can select the network it is not trying to connect to it. No weird characters or symbols in the network name either.