MQ3 sensor mini module i2

#1

Hi,
I am trying to connect the MQ3 mini module to raspberry 2. But when i use i2cdetect -y 1 to see i2c address for connected device, i see no address assigned to this sensor. Kindly help me out

0 Likes

#2

Hi,

Which adapter are you using connect the Raspberry Pi to the MQ3?

Does can you try to sudo the i2cdetect command to rule out permissions?

Some older models of Raspberry Pi use i2c bus 0 so you may try sudo i2cdetect -y 0

Is the power LED on the MQ3 lit up?

Can you send a photo of the hardware setup?

0 Likes

#3

I tried sudo i2cdetect -y 1 for my raspberry 2 and it shows the address.but nothing is assigned to MQ3 Yes Power LED is lit on MQ3. I tried to read the address for the sensor BME280 and it shows the address assigned to it. But no address assigned for Mq3 in I2C

0 Likes

#4

I can send you the image tomorrow as it is in the lab and i am not in the lab right now

0 Likes

#5

Well it should show up on 0x50 so there shouldn’t be an address conflict with the BME280 (0x76).

Is there anything else on the I2C bus besides the BME280 and the MQ3?

@Bhaskar do you have any suggestions to try?

0 Likes

#6

No Jacob. There is nothing else… do I need to install something on raspberry pi like cffi or something else

0 Likes

#7

i2cdetect should work, I’ve seen R Pi and linux in general have issues with addresses above 0x77, but not for a 0x50 address. Basically i2cdetect searches a default address range of 0x03 through 0x77.

Bhaskar may have a better idea though as he’s our I2C expert.

0 Likes

#8

Hello Jacob,
I was suspecting last time that we need an I2C interface adapter for raspi to interact with MQ3 module as the working voltage for the module is 5V and raspi works on 3.3V. But even after using i cannot detect the address for MQ3 using i2cdetect on raspi. Kindly help me out here.

0 Likes