MP44-20 will not accept configuration

Using the WEB UI, I was able to set the Transmit Interval from 3000 to 300000. When I adjust the Change Threshold the unit puts itself back in run mode. When I log back in the Change Threshold is back to a very low number.

I need to the Change Treshold to be 5 or 10 mA, so the radio only transmits at the Transmit Interval, not for an input change. Is there a range, or expected number of significant digits, that needs to be entered? I have tried numbers from 0.0234 to 20.0 and every time I hit the “SAVE CHANGES” button the unit just bounces out of config mode.

Any ideas?

To be clear, I think that by standard operation the MP44-20 might go to run mode each time the WEB UI “SAVE CHANGES” button is pressed.

My issue is that I cannot modify the Change Threshold value:

  1. I connect to the MP44-20 using my phone
  2. I put a value in the Change Threshold setpoint " 1.000 "
  3. The MP44-20 goes back to Run mode
  4. I re-connect to the MP44-20 using my phone
  5. The Change Threshold setpoint is back to " 0 "

I have tried this at least 10 times, using different values and significant digits, such as " 0.2500 ", " 1 ", " 0.750 " etc. None of these values I enter become the setpoint, the MP44-20 always reverts back to a different value.

With a very low, or zero, value for the Change Threshold the Transmit Interval will not function: a 4-20 mA signal will always vary a little bit: a 6 mA value will be 5.94, 5.98, 6.01, 5.96, etc. For some 4-20 values, this signal “wobble” can be significant, up to +/- a mA. If the Change Threshold cannot be programmed, then the radio will constantly transmit these value “changes” that are insignificant to the process.

Any ideas would be appreciated.

Hi @richard.vaughn,

It is normal for the device to reboot into run mode after clicking the Save Settings button.

The Change Threshold limit should be entered as mA. So if you wanted the device to transmit when the input changed by 5mA or more you would enter 5.00 as the change threshold.

If the values you are entering are not storing the only thing I can think of off the top of my head is somehow the settings file being corrupted. You can restore factory default settings by factory resetting the device. To do that put it in config mode(flashing Blue LED), then press and hold the Config button until the LED begins flashing random colors. Keep in mind however that doing so will require a full restoration of settings including the mating device’s serial ID and recalibrating the board for input values.

Let me know what you find.

Thank you,
Travis Elliott

Hi @TravisE_NCD_Technica ,

Reset unit to default by pressing and holding config button until LED flashed random colors.

Connected to WEB UI, Destination has not changed, Timeout has reset back to default 3000.

Changed Timeout to 300000, Change Threshold to 5.00.

Re-connected to WEB UI, Timeout is still at 300000, Change Threshold is .008 (did not accept Change Threshold).

Tried again, this time Changed Timeout to 300010, Change Threshold to 1.00.

Again re-connected to WEB UI, Timeout is at 300010, Change Threshold is .006 (did not accept Change Threshold).

Are you able to configure a Receiver on your test bench with a Change Threshold of 5.00 mA ?

Hi Richard,

Thank you for the update. I will get a device here to my desk and diagnose the issue. I will get back to you this afternoon. I should be able to find and fix that bug fairly quickly. Once I do I will send instructions on updating the firmware on your device.

Thanks, I will wait to hear back.

@TravisE_NCD_Technica you can stand down, @jpugh figured out the issue for us

Hi richard. I have the same issue, I can’t change the Threshold, everytime i change it go to 0.

How did you solve?

When you modify the Change Threshold, the value you enter is in millivolts mV. After you save the settings, the unit will bounce you back in to Run Mode. When you press the Config Mode button and go back online with your web browser, the Change Threshold value you view is in milliamps mA.

I would guess that you are attempting to enter a value in milliamps, and it is too small. Try this: Enter 2700 in the Change Threshold setpoint box. After you save the settings, the unit will bounce you back in to Run Mode. When you press the Config Mode button and go back online with your web browser, in the Change Threshold value you should see 5.00128 or close to that. That means your Change Threshold is now 5.00. If the MirPro does not see a change of at least 5.00 mA, it will not transmit until the time interval in the Change Interval setpoint.

Remember that you must record the Change Threshold equiv value in millivolts mV. If you modify any other value in config mode, you must also enter the Change Treshhold equiv value in millivolts mV.

This is an issue that will trip a lot of MirPro users up. Almost all MirPro users should modify the Transmit Interval and Change Treshold values. Worse, the issue, and the workaround, have not been documented by @NCD. @NCD should address this as soon as possible.

Post back if the tips I have given you don’t do the trick.