Motion Sensor Capability & Setup


I just received an IoT Long Range Wireless PIR Motion Detection Sensor [product-page] and I’d like to find out how effective it would be for detecting objects like boards moving past it? I assumed from the description that any object would do but after reading through it again the emphasis seemed to be on human detection.

My second question is about transmitting data from the sensor. I ordered a micro gateway [product-page] assuming it would be compatible but I haven’t had any luck connecting the two devices. Do I need a different gateway device?

Thanks! Let me know if I can elaborate on anything.

It mostly used for humans but it can be used with other objects as well.

It should work with the gateway you have. You might have to update the firmware.
@TravisE_NCD_Technica its sensor type 46.

1 Like

The MQTT Gateway does not currently support that device. I will add support for it in the MQTT Gateway firmware today.

Once I have updated the firmware you can update the firmware on your Gateway by following the instructions in this document:

I will let you know as soon as the firmware update is available.

Thank you,

1 Like

I just added support for that sensor to the MQTT Gateway firmware. You can go ahead and update the firmware on your Gateway as explained above.

1 Like

Thank you for the quick responses and firmware update @TravisE_NCD_Technica! I will update and test my gateway this afternoon or tomorrow.

Hey @TravisE_NCD_Technica I’m having trouble running the script. I get to the second step and the script gives me this error:

I tried without the gateway connected as well and it shows the same error.

@andrasm You’re seeing a permission error in your local repo that seems to have set firmware.bin to be read-only. The script fetches the latest .bin files from NCD and downloads them, saving them in the repo, overwriting the ones that are already in the repo. (BTW @TravisE_NCD_Technica , I have a PR that can prevent this from occurring in the future. :slight_smile:)

@andrasm Use the windows explorer and check the properties of the .bin files. Make sure they are not read-only. Then re-run the script.


@ybakos, sorry, I missed that PR somehow.

@andrasm you can try downloading the Flash Script from Github again after I merged the PR from @ybakos and give it another go.

1 Like

@TravisE_NCD_Technica It’s a new PR that ignores and removes the .bin files. (.gitignore: Ignore .bin files and remove from the repo. by ybakos · Pull Request #3 · telliottosceola/Flash_Script · GitHub).

It seems the script always downloads the latest firmware bins, so there’s no need to have a saved version in the repo. The .bin files in the repo are far out of date anyway, I believe. :slight_smile:

1 Like

Got it and addressed on GitHub repo. Thank you @ybakos