Mirco Gateway Losant - Wifi Connectivity issue

I have just received my mirco-gateway. I have followed the instructions to connect it to my network, however it cannot seem to find any wifi networks and i cannot figure out how to reset the device so that networks will show up. When browsing to the devices IP, the field for Networks is blank and will not show me any available wifi networks that are within range of the gateway.

You can attempt a factory reset.

  1. Power off the Gateway.
  2. Press and hold the CFG button inside the Gateway.
  3. Re-Apply power to the Gateway.
  4. Continue holding the CFG button until the LED turns Blue.
  5. Once the LED is flashing Blue Press and hold the CFG button again until the LED turns off or goes solid Blue.
  6. The device will reboot and should be factory reset so it should boot straight into configuration mode.

Hey Travis,

I have tried your steps listed. Still the same thing. Is there a way to reflash this device to see if its something within its config file that is wrong.

This is the result i get for the network.

Ah, that’s a Losant Gateway. Sorry I missed that in the title. I saw Micro Gateway and stopped reading.

To be 100% honest we have sold about 2 or 3 of those in history. Let me take a look and see if I can figure anything out that may be causing an issue.

Sounds good Travis,

It connected to our wifi network the very first time that i booted it up, however i didnt have my losant gateway ID correct and so when i hit save, it didnt connect to the network. Ever since then, it will not even find the wifi networks. Maybe it needs a firmware flash?

Hi Andrew,

You could certainly give that a try. This document outlines how to flash firmware:

Let me know what you find.

Hey Travis,

No joy on this solution. Cannot get the serial to connect to this little guy. When I connect the unit to my PC via the USB cable, I get nothing. I go to my device manager and it is not picking anything up on my comm ports to say that the device even registers. I know that the cable works as it is providing power to the unit and I have tried several cables. Is there anything else that I can do? Can I return this unit and get another one? I ordered this for a job that I need to complete…

Did you install the SI Labs VCP driver? That is required for the device to mount to the OS.

Also many USB micro cables are charge only cables. They provide power to the unit but don’t actually have data lines. These were very common for Android Phones. I would make absolutely certain you have a data cable and not a charge only cable.