Issues uploading data from 2-channel sensors to AWS Gateway?


I recently received an AWS Gateway and a 2-channel vibration v3 sensor for use on a project. I’ve been able to configure both to the settings I want and as far as I can tell both seem to be working as individuals.

However, the sensor and the Gateway are having trouble communicating with one another. Even though both are on and sending out info, no data is being uploaded to AWS. I’ve checked the gateway settings and the gateway is able to identify the sensor but I don’t think it’s picking up the vibration information.

I’ve checked in node-red and I know the sensor is working and sampling data at the 1-minute rate I set it to and when I used an older 1-channel v3 vibration sensor with the gateway the data was able to be uploaded without any issue.

I’m not sure what else I should try so any help is really appreciated.


These do not support one-minute intervals. That’s only for debugging purposes.
Change the interval to 5min.
also, AWS gateway is recommended for configuration. we recommend node-red. These sensors have hundreds of settings parameters and AWS gateway does not support al these settings.


I know this is my old post but I’m encountering another issue with the 2-channel vibration sensor and its connection with the AWS gateway.

Recently, we’ve found that after we factory reset our sensor and reconfigure it to our desired settings, the sensor loses connection to the gateway. The sensor is able to connect after the reset but every time we have configured it, the sensor and the gateway stop talking, even though the sensor is still sending information (I confirmed this using our mega modem and node-red).

I ran a little trial and error experiment, and found that the one sensor configuration setting that seems to cause the lost connection is “Set Dead Band in mg”. For our use of the sensors, we’ve had to set this to zero in order to pick up the small vibrations we’re looking for. When we configure the sensor back to a higher value for this setting, the gateway is able to send the sensor’s data but it stops when we set it back to zero.

Why is it this setting which causes the issue and not some of our others?

Setting the deadband to zero should not cause any issues. This is a very command settings user use.
Are you getting data on the mega modem or node-red after setting deadband value to zero ?

I’m able to see the data in node-red after setting the dead band to 0 but the data does not appear on AWS.

So the sensor is working as it should.
You get data on AWS is you set the sensor headband to non zero but no data if you set the headband to zero?

Yeah, that’s pretty much the situation. I did try setting the dead band to 0.001, and that too caused the data to not appear.

Setting it to 10 mg, which I thought was the default, gets it back.