Failing to connect to ProRX Digital Potentiometer using Base Station Software or Industrial-Relay-Control library

I am trying to connect to the 24-Channel 256-Step ProRX digital potentiometer (SKU: PR60-21C_ZPOT24PROXR), and I have not been able to communicate with it. I have the Ethernet to Serial Communications Module, and I have tried using both the Base Station software, and the python helper library: GitHub - ncd-io/Industrial-Relay-Control.
When I use the Base Station software, I see the device under the network section, but when I attempt to connect to it, the window that pops up presents the error: “Device Identification Failed." I have read several of the posts on the forum about this error, but none of the solutions, such as connecting using a network switch have resolved the problem. With the device plugged into our network, I looked up its MAC address on our router. It is did not even register as connected at all - it didn’t exist at the big network level, which seemed to imply it was not communicating at all.
I decided to try to circumvent the base station software, and attempt to communicate using python, which is my goal anyways. I used the Industrial-Relay-Control library, with the following code:

import socket
import ncd_industrial_relay

#set up your socket with the desired settings.
sock = socket.socket(socket.AF_INET, socket.SOCK_STREAM)
#instantiate the board object and pass it the network socket
board1 = ncd_industrial_relay.Relay_Controller(sock)
#connect the socket using desired IP and Port
PORT = 2101
sock.connect((IP_ADDRESS, PORT))

This resulted in an

ConnectionRefusedError: [Erno 111] Connection refused

I also do not see any LED activity on the Ethernet Connection Module itself, although I am not sure if I should.

It seems to me that there might be a problem with either the module or the board itself, but I am not sure. I would welcome any advice on how to narrow down the problem.


It sounds like the settings in the Ethernet module could possibly be incorrect.

I would recommend reviewing this guide for the Ethernet module which covers how to configure it’s settings:

Make sure the serial interface baud rate of the module is set to 115200 and the work as setting is set for TCP Server(listening/local port set to 2101). Then try Base Station software again.

Also keep in mind only one TCP client connection is permitted to the NCD5500 Ethernet module at a time so make sure any other software which could be connected to the device is closed.

Thank you,
Travis Elliott

Hi Travis,

I checked the config for the module, and it was already at the what you recommended. I tried to access the IP ( through my browser, and it did not connect. I have included a picture of my config settings, and the error I see when trying to access the static ip through my browser.


A couple of months ago there was a bug in the firmware of the Ethernet Modules which has since been fixed. It looks like your module has this bug.

To solve the issue you can use the following instructions to upload the latest firmware.

At this point you can set the module to DHCP or factory reset it.

If you get an error message saying you cannot talk to the device you will need to set a static IP address on the module first that will be on the same subnet as your computer/router.

Hi Jacob and Trevor,

I attempted to upload the firmware, using both the factory set static ip, and an ip address in my own subnet, and neither worked. I have included pictures below.


You may have an unusual network. The IP address listed in the top left is the IP address of the NIC being used to try and make these connections. The IP there is in the subnet 169.254.146.x

Additionally the Gateway you’re configuring into the module ends in x.x.x.254 which is somewhat unusual as gateways usually end in x.x.x.1

This all depends on your network, but if you’re unsure you can try something like these settings: