Extend contact closure from one site to another


#102

I’m going by memory here, but I though Brian mentioned he purchased a 1.5 amp board.


#103

The specs on-line for the board said it came with a 1.5-amp supply. That’s when I queried Travis, but he said it’s a 2-amp supply. I just went out and connected the battery and didn’t think to look at the power supply to see what its label said. I can do that later, but I’ll have to unplug the power supply first and I’d prefer to let the whole thing run for a while with the battery connected to see if there is any improvement in reliability due to that change alone.


#104

Yeah, I’d let it run for a bit with the Battery and see how it does. Not sure if the labeling on the board will be accurate or not.


#105

@Bhaskar
Can you confirm what the 5VDC regulator circuit on this board is rated for(current)? I think you beefed up the PS on this board for the Electron but can’t remember the rating 1.5 amp, 2 amp, etc?


#106

BTW, while we’re on the subject of signal strength, take a look at the attached photo. The NCD relay board with Electron is in the enclosure in the middle. Do you think there might be some detrimental electromagnetic interference affecting same?


#107

I’ll be the first to admit I am NOT a wireless engineer. Looks like a plastic Enclosure which is good. Id say we really shouldn’t try to speculate on much until the battery connected experiment is concluded. At that point we could start thinking about external antennas and such if needed.


#108

This board has the 2Amp power supply.


#109

Agreed. Connection seems stable at the moment (knock on wood).


#110

Side Note: I installed an Electron this Saturday on a Hog Trap.
The area has invasive Wild Hogs, and we use live traps.
The electron wakes up every 4 hours from Deep Sleep to tell me if any Hogs have been caught.
I use a 5Ah Li-Po and 6V Solar Panel.

The trap is in an extremely rural area, deep in the woods, very poor cellular coverage, and a 2 hour drive from my house.
It missed the first few check-in’s Saturday, but eventually started publishing and works fine.
I’ve had this happen several times in areas of poor cellular coverage. I just left it alone and everything worked out.


#111

Well, that has to be a one-of-a-kind application! Good news about reliability. I’m afraid to jinx anything, but my Electron that now has an attached Li-Po battery has maintained a solid connection - in the rain - for about 2 hours now…

Update: 3 hours so far.
Update #2: 4 hours so far w/o a hiccup.
Update #3: 5 hours so far w/o a hiccup except log stopped populating again until I ran another set of diagnostic tests, then resumed. Still no more disconnects.


#112

That is great news but kind of makes me wonder why the LiPo is required. I wonder if a change to Particle’s OS has caused this. I know it ran fine in the past on 0.6.0 but I never tried upgrading OS. Could also possibly be a hardware change on Electron, hard to say without opening a discussion about them. What matters is a functional device though so if it works for you reliably that’s all that matters.


#113

I will be providing Particle with a summary of all of this once we have come to some kind of reliable conclusion.

But here’s a perplexity: the Particle console has stopped showing log entries for the device in question, yet it still responds to pings and passes all tests. Furthermore, the number of disconnects at the time I connected the battery - 41 - has not incremented; it had been doing so one or more times per hour.

I think the log problem is related to OS 0.8.0 rc11. If/when it appears that the connection to the cloud is reliable, I will be reverting to OS 0.7.0.

Update: after I ran the test suite, the log started to populate again; seems to support my suspicion that that particular issue is OS-related.


#114

Hey Travis, did you see my message from Friday? Your modified app wouldn’t compile and the video you provided was empty.


#115

@Travis and @Bhaskar ,
Brian may be having the issue I messaged you on August 18’th (NCD forum) concerning Particle’s 0.8.x firmware with NCD relay boards. We had some discussion via email also.
The solution was use the Li-Po if you need Firmware 0.8.x for now.


#116

Ryan: I hadn’t mentioned this before but yesterday when I was having significant connectivity issues, I watched the Electron in question for quite some time. When I first started, I found the LED rapidly flashing cyan for several minutes. It never started to “breathe” cyan. Then it changed to breathing blue for a short period, then to flashing green and then back to rapidly flashing cyan again. Repeated until I got tired of staring at it.


#117

Travis: I found this post from Rick @ Particle from September 3rd in response to a comment on their forum from one of their customers about 0.8.0 rc10:

“You can use the Electron without the LiPo if you have a power supply that can supply 2A, and do so fast enough for the very short power bursts in the cellular modem. You may want to disable the charging LED as well. If you don’t have sufficient power, you probably won’t be able to connect to cellular or connect to the cloud. It will also vary depending on how far away the cell power is (farther away = more power required).”


#118

Great news guys! The Electron running 0.8.0 rc11 has remained solidly connected to the cloud without a single disconnect for 17 hours now. Clearly, power was the issue and connecting the Li-Po the solution. Many, many thanks for pointing me in that direction Travis and Ryan!! I can sleep thought the night again.


#119

HELP!

After remaining solidly connected the the cloud with zero disconnects for well over 24 hours since I connected the Li-Po batteries to my Electrons, the Electron at the tank started ending '1’s for the first time about an hour ago, indicating for the first time since yesterday that the float switch had closed. Just to make sure that the pump was actually on, I went to the well site to check the R1 LED. It was not on! I crossed the COM and NO terminals with a wire and heard the pump relay in the wellhead come on, further proving that the relay had not closed.

Bottom line: although both Electrons remain in a ‘breathing’ cyan mode, are ping-able and pass the diagnostics tests, the relay doesn’t close.

What might be going on?


#120

Are you sure you have the correct Code flashed to the Electrons?


#121

Hi Brian,

Not sure on that one. Are you getting logs on PaperTrail saying the relay is kicking on and off? If you are then it is hardware related. If not it may be something with the application code but that application code is dead simple(not much to go wrong there I wouldn’t think.

Also can you confirm that this was working previously? Pump was kicking on?