Encryption setting fail

#1

Hello,

I tried several times to set encryption between a wireless industrial vibration sensor and a wireless usb router. But I failed everytime. What I did is:

  1. Enable encryption on the sensor using the labview utility
  2. Set the encryption key for the sensor. I used a key very easy to remenber
  3. Then I enabled the encryption on the router
  4. Finaly I set the encryption key for the router (obviously I used the same that I used for the sensor)
  5. I took care to set the PAN ID to 7FFF after these modifications.

Then BOOM !The router is unable to reach the sensor. I have to factory reset the sensor to make them work together again.

Do you have an idea of what I could do ? Thanks in advance for your help :slight_smile:

0 Likes

#2

i think you used a very short encryption key.
Looks like we need to repeat the factory reset settings( like we did earlier) and use a 32 byte key.

Thanks

0 Likes

#3

Hello Bhaskar,

I used a 32 bytes key. To keep it simple I choosed…
1234 5678 9012 3456 7890 1234 5678 9012

Do you think that I did the operations in the correct order ?

0 Likes

#4

just tried exact key over here and it works.
so lets do this factroy reset both sensors and the router and make sure they communicate.
after that put the sensor in cfg mode
set the new key 1234 5678 9012 3456 7890 1234 5678 9012 ( you done need to enable key key, its already enabled by default)
at this point we wont change anything else.
now hit reset and apply the same key to the router. and go to run mode and hit reset on the sensor and you should see data on the ui

0 Likes

#5

Hello Bhaskar,

Sorry for the delay… I had to travel to meet a client.
Once again, your advice worked perfectly. Once again you saved my day :slight_smile:
Are you part of the ncd.io team? You seem to know the products so perfectly.

Thanks for your help !

0 Likes

#6

Hi Bertrand,
Glad to know you have it working.
I am lead design engineer of this product line :slight_smile:

Let me know if you need anything else.

Cheers!!!

1 Like