Contact Closure Email Generator issue

I work for a university and am trying to install the email generator to monitor the burglar alarm at the President’s house. I am having issues with the initial configuration. I am not confident it is getting a connection but was hoping there was some way for me (someone without admin access to the network) to see if it’s pulling an IP.

Our wifi network is set up as a captive portal where the user needs to accept the AUP and register the device before it gets dropped on the network. I have worked with our networking team to manually create a MAC reservation so this device could bypass that process.

When the device boots it immediately starts into a rapid light-blue/white flashing. I can press the mode switch to go into config mode and it is a slower dark blue flash. When I press the mode switch again it flashes green a few times then drops right back into the rapid light blue/white flash.

I plan on taking it home to verify that it is working with the g-suite account we set up but the more info I can gather on my own before calling the network team the better.

Flashing White LED indicates the device is attempting to establish connection to the WiFi network. From what you have described it sounds like it is not able to connect to the WiFi network.

I second your suggestion to take it home and verify it’s functionality there. If it works there then you know the issue is with authenticating with the WiFi Network.

The saga continues. I was able to work with the network team and convinced them to spin up a separate SSID just for this device. Everything was working flawlessly. I had customized the email bodies for each input and configured the recipient list. After testing each one I was asked to add a recipient that was forgotten. I pressed the mode switch, waited for the blue flashing, connected to the network, but the page wouldn’t load. I glanced over at the device and the LED was on solid and was a purple color, like red and blue at the same time. I unplugged the power for 30 seconds and plugged it back in, now it just sits there with the purple LED. Multiple reboots and presses of the mode switch have done nothing. It appears to be bricked. Is there some kind of factory reset that can be done on these?


You can attempt a factory reset.

  1. Disconnect power.
  2. Press and hold the CFG button.
  3. Apply power.
  4. Hold CFG button until LED turns blue. Then release.
  5. Once LED is flashing Blue press and hold CFG button until the LED flashes random colors.
  6. Device should reboot in CFG mode as it is now factory reset.
  7. Open web interface and enter configuration settings again.

Let me know if this works.

Thank you,
Travis Elliott

Hi Travis,

No such luck. It is completely unresponsive to any input on the CFG button. As soon as I apply power both the red and blue LEDs turn on constant and stay that way no matter what I do.

Is there any way we can just reflash the software on it?


Hi Josh,

Yes, you can flash the firmware over the USB connection on the device.

See instructions here:

Let me know if you have any questions on this.

Thank you,

Well, after spending an embarrassingly long time trying to track down a microUSB cable that actually had the data pins wired up, I got it to show up in device manager. However, the script appears to be timing out.

Hi Josh,

I apologize for the delayed response.

Not all USB hardware drivers are able to automatically put the module into PGM mode. This is what is happening when you see the terminal print …_. It is trying to put the module into Flash/PGM mode. Looks like the USB port on this computer is not able to use the DTR/RTS lines to control the mode. It’s an easy fix however.

  1. Press and hold the RST button on the processor module near the USB connector.
  2. Start the script.
  3. Once the terminal starts printing …_____…etc wait until the ______ prints, then just before it starts printing … release the RST button. This should put the module into flash mode and you will see it start to flash the module. You can retry this as many times as you need during the sequence as it can be hard to get the timing just right.

Let me know if you have any questions on this.

Thank you,
Travis Elliott

Hi Josh,

Firmware on update server is ready to refresh your device. Let me know what you find.

Hi Travis,

I was able to successfully reflash it but when I remove power to reinstall it in the enclosure it reverts back to the solid purple LED. It has done it three times in a row now. The location it is installed at loses power somewhat frequently, and the power on email function was one of the primary selling points for us, but it obviously doesn’t do me any good if it needs to be flashed every time it reboots. Can we send it in for repair or swap it out for another one?

You said you refreshed it then installed back in enclosure. Did you configure settings or just flashed and put back in enclosure?

If you did configure settings can you provide screen shots of the configuration settings you loaded into it? If you just flashed and this happened let me know.

I tried it both ways. The first time I configured the wifi, email, and input settings. The following two times I powered it down as soon as the script was finished, immediately slid it back into the enclosure and powered it back up.

A solid purple LED is normal after boot up for approximately 6 seconds or so. However eventually the LED should start flashing Blue after a fresh update.

It has been sitting at a purple LED since the last time I rebooted it. About 40 minutes now. It functions normally after a fresh update but obviously I have to unplug it in order to get it back into the enclosure. Once it is powered down and back up again it, it hangs on the purple LED.

I can flash it again and it will work fine, until it loses power. Then I’m back at square one.

I just used the same python script here to flash an ESP32 module and everything worked as it should. I guess the only difference is I do not have the ESP32 module installed in a board. It’s just sitting by itself and is powered by the USB cable(unplug module from board). Could you try that? After flashing just disconnect/reconnect the USB cable to see if it does the same thing.

Also please confirm you are selecting firmware option 13 during the flashing process.