Cannot access Fusion Web-I through browser, but Basestation can


#1

I have six Fusion boards installed at remote sites. They are configured for DHCP (reserved) with port forwarding. I can ping them, and I can communicate to them through Basestation, but when I try through a browser or the IORelay app, I cannot access. The routers they are behind have static IP five 8 packs, but the addresses we are hitting from the outside are the gateway IP addresses. End user is getting concerned.


#2

Hi,

What ports are being forwarded and to what port on the device?

What error message does the web browser display when you try to access these devices over the internet?

Does this same error happen when you try to connect to them locally?

One thing that may help in troubleshooting is understanding that if a program like Base Station or IORelay TCP has a connection open to that device then no other application can open a socket to it while that original socket is open. This holds true for the Web-i’s web interface in so far as sending commands goes. The reason for the web interface hang up is that the socket on the Web-i is consuming the serial port so that web interface can’t use it. Basically only one control method is allowed at a time.


#3

Ports 80, 8080 and and 2101. The Web-I is on device port 1. The Chrome web page just comes up “This site can’t be reached” The weird thing is, they each worked fine while our tech was onsite, I was able to access them remotely through Web-I, so something changes. No other programs are open on these to hold up the port, I’m familiar with that, and those release pretty quickly.


#4

Are you using Base Station on the same local area network as the devices or are you manually typing in their connection information for each remote device?

Can you test the functionality of Base Station, IORelay TCP, and the web interface locally (making sure you’re on the same network as the device and accessing its local IP address) and see if they work so we can isolate if its a module issue or a connection issue?

Can you send a screenshot of the current port mapping on these routers for these devices?


#5

Manually typing in IP addresses. I can’t send a screenshot of the routers without visiting the site. I can provide all of the IP addresses but not on this public forum.


#6

If you open a ticket at https://ncd.io/contact-us/technical-support-for-ncd-industrial-devices/ we can exchange this information.

Ideally we could check the web interface from a local area connection to make sure we can narrow down the source of the issue.