Azure MQTT Gateway and Sensor not communicating

I have a micro gateway (PR55-21 MQTT) that was flashed to be an azure gateway and a Temp/Humid sensor (PR49-24G) that I am trying to connect. Order Number: #385663

I have been able to connect the gateway and Azure but when I look in the device twin I do not have a nodes object as described in the quick start guide. When set the gateway to config mode and connect to it there are no devices in the devices tab.
However if I turn on config mode and set the sensor to config mode I can get a Mac address to show up (See attached screenshot)

Even then I do not get any of the other data in any of the columns and nothing in my device twin, nor am I getting and Device to Cloud messages.

I have tried this setup with the antennae unplugged and close to each other, unplugged and across the room (14 feet or so), antennae plugged in and close to each other, plugged in and across the room. They all have the same results.

Is there anything else I am missing?


Hi Mark,

That is a new sensor. We had recently added support for it to The MQTT Gateway but had not yet added support for it in the Azure gateway so what you are describing makes perfect sense. Let me rebuild the Azure firmware to add support for that sensor and I’ll update the firmware server. You’ll need to update the firmware once again after I do that. I will let you know when it’s ready.


Thank you for your rapid help and support.

Should be ready Mark. Go ahead and refresh the Azure firmware and let me know if you have any problems.

Thank you,
Travis Elliott

That worked like a charm.

Awesome. Let me know if you need anything else.