Almost no response in current when 2 wire sensor is connected with Wireless 4-20mA Current Loop 4-Channel Input endNode

Hi. I have newly purchased a Wireless 4-20mA Current Loop 4-Channel Input endNode and started testing yesterday.

Follow the instructions here

Part 1

Unlike the USB modem, the endNode needs 12V power first and then connect the USB in order to get it running.

I am using the same sensor which has been tested okay with 2 Channel Industrial IoT Long Range Wireless 4-20mA Current Receiver link. Sensor itself supports 9-25V DC.

May I know where could I set the current loop input supply 10V, 16V & 24V to external sensor?
No option to choose the input when doing the purchase.
If you need the order#, Order #510460

Before the connection. I got this.

After the connection to input 1. I got this.

The wiring is straight forward so I don’t think the connection is wrongly made. The wires are exactly the same in other trial so wire condition should be no problem.

Any idea what’s going on with the 0.685mA but not 4.0mA +/-?


Part 2

I try following the section of Wireless Communications in link

=>Plug the USB Modem into the USB Port of your computer (Done)
=> and make sure the power connector is plugged in (Uusally I just plug the USB cable to get Alpha Station running but this time I connect the modem with power source too. Done)

PC <=> USB Modem (Connected with power source)

EndNode (Connected with power source. No sensor is connected at input. No USB is connected)

Then I started the Alpha Station. Checked the option and double confirmed with the serial ID of EndNode. Press OK

Then I got these.

Nothing is shown up.

I expected something like this shown up.

May I know what steps I might have made wrongly?

PS: I tried Wireless 4-20mA 4-Channel Input endNode and everything is fine. Not sure if my current loop device is not current loop.

Should I connect the sensor in the way of non current loop? Not so sure if it might do harm on the hardware.

  1. does your sensor already has loop power or not? If not, then you can connect to this device. you might try swapping the wires. I don’t have any info on the sensor you are using, so I can’t tell how it works.
  2. I don’t see anything wrong with your wireless setup. @ryan1 any comment
  1. The sensor has no loop power. It works okay with [4-20mA current receiver]. (
    You could read this Post. The receiver is exactly almost the same type relying on the on board supply to power up the 4-20mA device. Wires are swapped and replaced. The wires are exactly the same in other trial so wire condition should be no problem.

How are you providing the power?
can you share an actual setup diagram?

Hi. I thought the setup is as same as the current loop sensor which I tried before and worked well

It says

  • On Board 16V Supply to Power up the external 4-20mA Devices

And now this another type of current loop receiver also got this on the highlight, saying

  • Isolated 4-20mA Current Loop Inputs Supply 10V, 16V, or 24V to External Sensors

Am I making any mistake or any wrong concept I have been dealing with so far?

These are two different items.
Thats why I asked for

  1. datasheet of the sensor
  2. actual wiring diagram