AD5252 Digital Pots and AnyI2C


#1

I just purchased AD5252 digital pots and the 12c <-> USC converter.

I try to connect to it via NCD Base and it says it cant find it.

If I use AnyI2C, it appears to connect to the com port (com 1) but I get write failures trying to communicate with the AD5252’s.

I am in windows 7.

I have 3 AD5252’s and I have given each a unique address.

Any help communicating with the device would be great!


#2

Hi,
Does the board show up when run the i2c scan?
Make sure you are using the correct i2c address in the UI.

Thanks


#3

I do Open the connection withthe default settings and it says connection opened.

When I do the Scan I2C Devices button, it comes back with nothing.

How do I know what the address is?

That all being said, I think i might have an issue with the virtual com ports… I see the Serial Converter, but I dont see any com ports created for this.


#4

this might be related to ftdi driver in that case.
does the com port shows up in the device manager ?


#5

I tried to update the driver and it said it was up to date, I downloaded the latest from ftdichip dot com.

I see only com 1 only which is there regardless if i have the hardware plugged in or not. I dont see any other com ports present in device manager.


#6

this guide might help in troubleshooting


#7

Yea, I saw that yesterday. It doesnt help.

I am on win 7…


#8

do you happen to have any other PC you can use for testing?


#9

I just tried it on another PC I just happened to have at my desk that is non-corporate… and it worked… guess corporate policy wins again grrr…