4 channel 4-20mA receiver


I am having problems with the 4 channel 4-20mA receive module. Sometimes it works most of the time it doesn’t. Does anybody have experience with this module?. The I2C codes are sent as i confirmed with logic analyser but noting is being sent back from the MCP3428 IC. Could it be a conception problem as i don’t see no decoupling capacitor near the MCP3428. Any help would be greatly appreciated.

Thank you!


  1. does it send wrong value or no values at all?
  2. what is the i2c cable length
  3. does your master device has pull ups?



  1. no value sent back

  2. cable under 10 inches

  3. I use a i2c level shifter between master (Cortex M0) and slave (MCP3428) ,
    the pull ups are ON on the 5V slave side but i have no pull ups on the 3.3V
    master side of things. I tried to put some on the 3.3V side but no change.

    This is the level shifter that is use:

the level shifter could be the issue. I will recommend using a full i2c level shifter.

I never used such transistor based level shifter with i2C but i have used these with UART and haven’t had much luck with these.

do you happen to know if your master device is 5V tolerant or not?

The feather M0 from Adafruit is the master device that contains a ATSAMD21G18 Cortex M0 unit
and i think it is 5V tolerant (5V output with pull-ups) but need more investigation on that will post back.
Anyway i tried with direct connections and it didn’t work… i will try again.

thank you